xf86-video-omapfb: pandora: handle cycle/forcer events better
[openembedded.git] / recipes / musicpd / mpd-alsa_0.11.5.bb
1 DESCRIPTION = "Music Player Daemon (mpd). This version is configured for alsa support"
2 HOMEPAGE = "http://www.musicpd.org"
3 SECTION = "console/multimedia"
4 LICENSE = "GPLv2"
5 DEPENDS = "libvorbis libogg libao-alsa zlib libmikmod flac audiofile virtual/libiconv \
6            ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad libid3tag', d)}"
7 RDEPENDS = "libao-alsa"
8 PR = "r4"
9
10 SRC_URI = "${SOURCEFORGE_MIRROR}/musicpd/mpd-${PV}.tar.gz \
11            file://mpd/save-volume-state.patch;patch=1 file://mpd/mpd.init"
12 S = "${WORKDIR}/mpd-${PV}"
13
14 inherit autotools update-rc.d
15 INITSCRIPT_NAME = "mpd"
16
17 # Setting --enable-mpd-{mad,id3tag} causes local caches of the libraries to
18 # be built, instead we use the OE built versions which should be installed
19 # in staging - remove the --with and replace with --enable to use the local
20 # versions.
21
22 EXTRA_OECONF = "--enable-ogg \
23                 --with-iconv-libraries=${STAGING_LIBDIR} \
24                 --with-iconv-includes=${STAGING_INCDIR} \
25                 --with-vorbis-libraries=${STAGING_LIBDIR} \
26                 --with-vorbis-includes=${STAGING_INCDIR} \
27                 --with-ogg-libraries=${STAGING_LIBDIR} \
28                 --with-ogg-includes=${STAGING_INCDIR} \
29                 --with-ao-libraries=${STAGING_LIBDIR} \
30                 --with-ao-includes=${STAGING_INCDIR} \
31                 --with-id3tag-libraries=${STAGING_LIBDIR} \
32                 --with-id3tag-includes=${STAGING_INCDIR} \
33                 --with-mad-libraries=${STAGING_LIBDIR} \
34                 --with-mad-includes=${STAGING_INCDIR} \
35                 --without-faad"
36
37 do_install_append() {
38         install -d ${D}${sysconfdir}/init.d
39         install -m 755 ${WORKDIR}/mpd/mpd.init ${D}${sysconfdir}/init.d/mpd
40 }