Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[openembedded.git] / recipes / mamona / binutils-noemu_2.18.bb
1 PR = "r0"
2
3 require ../binutils/binutils.inc
4
5 RCONFLICTS = "binutils"
6 RREPLACES = "binutils"
7 RCONFLICTS_binutils-noemu-symlinks = "binutils-symlinks"
8 RREPLACES_binutils-noemu-symlinks = "binutils-symlinks"
9
10 SRC_URI = "\
11      ${GNU_MIRROR}/binutils/binutils-${PV}.tar.bz2 \
12      file://binutils-2.16.91.0.6-objcopy-rename-errorcode.patch;patch=1 \
13      file://binutils-configure-texinfo-version.patch;patch=1 \
14      file://binutils-uclibc-100-uclibc-conf.patch;patch=1 \
15      file://110-arm-eabi-conf.patch;patch=1 \
16      file://binutils-uclibc-300-001_ld_makefile_patch.patch;patch=1 \
17      file://binutils-uclibc-300-006_better_file_error.patch;patch=1 \
18      file://binutils-uclibc-300-012_check_ldrunpath_length.patch;patch=1 \
19      "
20
21 # powerpc patches
22 SRC_URI += "file://binutils-2.16.1-e300c2c3.patch;patch=1"
23
24 EXTRA_OECONF = "--program-prefix=${TARGET_PREFIX} --disable-shared"
25
26
27 do_configure () {
28     CC=gcc AS=as LD=ld CXX=g++ AR=ar OBJCOPY=objcopy OBJDUMP=objdump RANLIB=ranlib NM=nm STRIP=strip oe_runconf
29 }
30
31 do_compile() {
32     make configure-host LDFLAGS=\"\" 
33     make LDFLAGS=\"-all-static\"
34 }
35
36 do_stage() {
37     :
38 }