Merge branch 'master' of git://dev.doredevelopment.dk/oe-micro into org.openembedded.dev
[openembedded.git] / recipes / mamona / bash-noemu_3.2.bb
1 require ../bash/bash.inc
2 PR = "r1"
3
4 RCONFLICTS = "bash"
5 RREPLACES = "bash"
6
7 SRC_URI = "${GNU_MIRROR}/bash/bash-${PV}.tar.gz \
8            file://001-005.patch;patch=1 \
9            file://006-add_internal_libcpwd_functions.patch;patch=1"
10
11 S = "${WORKDIR}/bash-${PV}"
12
13 EXTRA_OECONF += "--enable-static-link --without-bash-malloc"
14
15 #HOST_SYS = "${BUILD_SYS}"
16 #CONFIG_SITE = ""
17
18 do_configure () {
19     export CPP="gcc -E"
20     export CC=gcc
21     export AS=as
22     export LD=ld
23     export CXX=g++ 
24     export AR=ar
25     export OBJCOPY=objcopy 
26     export OBJDUMP=objdump 
27     export RANLIB=ranlib 
28     export NM=nm 
29     export STRIP=strip
30     export CFLAGS="-fexpensive-optimizations -fomit-frame-pointer -frename-registers -Os"
31     export CXXFLAGS="-fexpensive-optimizations -fomit-frame-pointer -frename-registers -Os -fpermissive -fvisibility-inlines-hidden"
32     oe_runconf
33 }