sg3-utils: add newer buildable version
[openembedded.git] / recipes / linux / openezx-kernel_git.bb
1 DESCRIPTION = "OpenEZX 2.6 Linux Development Kernel for the Motorola EZX GSM phones"
2 AUTHOR = "The OpenEZX Team <openezx-devel@lists.openezx.org>"
3 HOMEPAGE = "http://www.openezx.org"
4 SRCREV = "b390bb1ee708277297fdfd38e26d955b17d81c2e"
5 KV = "2.6.33"
6 PV = "${KV}+gitr${SRCREV}"
7 PR = "r4"
8
9 require linux.inc
10
11 # Make sure not to use thumb[-interworking]
12 ARM_INSTRUCTION_SET = "arm"
13 THUMB_INTERWORKING = "no"
14
15 SRC_URI = "\
16   git://git.openezx.org/openezx.git;protocol=git;branch=ezx/current \
17 "
18 S = "${WORKDIR}/git"
19
20 ##############################################################
21 # The kernel image used to reside on a seperate flash partition
22 # It can be flashed from userspace, so we should package it anyways
23 # (flash_unlock /dev/mtdX && flash_eraseall /dev/mtdX && flashcp /boot/zImage /dev/mtdX)
24
25 COMPATIBLE_HOST = "arm.*-linux"
26 COMPATIBLE_MACHINE = '(a780|e680|a910|a1200|rorkre2|rokre6)'
27
28 # The Kernel command line parameters are given via boot_usb or gen-blob
29
30 ###############################################################
31 # module configs specific to this kernel
32 #
33 #module_autoload_pxaficp_ir = "pxaficp_ir"
34 #module_autoload_snd-pcm-oss = "snd-pcm-oss"
35
36 do_configure_prepend() {
37         install -m 0644 ${S}/arch/arm/configs/ezx_defconfig ${WORKDIR}/defconfig
38 }