sg3-utils: add newer buildable version
[openembedded.git] / recipes / linux / mainstone-kernel_2.6.11.bb
1 SECTION = "kernel"
2 DESCRIPTION = "Linux kernel for the Mainstone (PXA270 ref design)"
3 LICENSE = "GPLv2"
4 PR = "r1"
5
6 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.11.tar.bz2 \
7            file://mainstone_defconfig"
8
9 S = "${WORKDIR}/linux-2.6.11"
10
11 COMPATIBLE_HOST = 'arm.*-linux'
12
13 inherit kernel
14 inherit package
15
16 ARCH = "arm"
17 #CMDLINE_CONSOLE ?= "ttyS0,115200n8"
18 #CMDLINE_ROOT = "root=/dev/slug rootfstype=ext2,jffs2 initrd=0x01000000,10M mem=32M@0x00000000"
19 #CMDLINE_ROOT = "root=/dev/mtdblock4 rootfstype=jffs2 mem=32M@0x00000000"
20 #CMDLINE_ROOT = "root=/dev/ram0 rw rootfstype=ext2,jffs2 initrd=0x01000000,10M init=/linuxrc mem=32M@0x00000000"
21 #CMDLINE = "${CMDLINE_ROOT} ${CMDLINE_CONSOLE}"
22
23 do_configure_prepend() {
24         install -m 0644 ${WORKDIR}/${MACHINE}_defconfig ${S}/.config
25 #       echo "CONFIG_CMDLINE=\"${CMDLINE}\"" >> ${S}/.config
26 }
27
28 COMPATIBLE_MACHINE = "mainstone"