sg3-utils: add newer buildable version
[openembedded.git] / recipes / linux / linux_2.6.32.bb
1 require linux.inc
2
3 PR = "r10"
4
5 S = "${WORKDIR}/linux-${PV}"
6
7 # Mark archs/machines that this kernel supports
8 DEFAULT_PREFERENCE = "-1"
9 DEFAULT_PREFERENCE_ion = "1"
10 DEFAULT_PREFERENCE_simone = "1"
11 DEFAULT_PREFERENCE_eee701 = "1"
12 DEFAULT_PREFERENCE_at91sam9g45ek = "1"
13
14 DEFAULT_PREFERENCE_akita = "-1"
15 DEFAULT_PREFERENCE_c7x0 = "-1"
16 DEFAULT_PREFERENCE_collie = "-1"
17 DEFAULT_PREFERENCE_poodle = "-1"
18 DEFAULT_PREFERENCE_spitz = "-1"
19 DEFAULT_PREFERENCE_tosa = "-1"
20 DEFAULT_PREFERENCE_ben-nanonote = "-1"
21 DEFAULT_PREFERENCE_jornada6xx = "-1"
22 DEFAULT_PREFERENCE_jornada7xx = "-1"
23 DEFAULT_PREFERENCE_ts72xx = "-1"
24
25 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2;name=kernel \
26            ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${PV}.9.bz2;patch=1 \
27            file://defconfig"
28
29 SRC_URI[kernel.md5sum] = "260551284ac224c3a43c4adac7df4879"
30 SRC_URI[kernel.sha256sum] = "5099786d80b8407d98a619df00209c2353517f22d804fdd9533b362adcb4504e"
31
32 SRC_URI_append_at91sam9g45ek = " \
33         file://at91/linux-2.6.32-001-configurable-nand-partitions.patch;patch=1 \
34         file://at91/linux-2.6.32-002-sam9g20-proper-reset.patch;patch=1 \
35         "
36
37
38 # part of 2.6.24.7 patchset from Sim.One project
39 # other patches needs work
40 SRC_URI_append_simone = " \
41                         file://ep93xx/edb9301-fix-machine-id.patch;patch=1 \
42                         file://ep93xx/simone-board-def.patch;patch=1 \
43                         file://ep93xx/ep93xx-regs.patch;patch=1 \
44                         file://ep93xx/ep93xx-i2c.patch;patch=1 \
45                         file://ep93xx/ep93xx-touchscreen.patch;patch=1 \
46                         file://ep93xx/ep93xx-spi.patch;patch=1 \
47                         file://ep93xx/ep93xx-cpuinfo.patch;patch=1 "
48
49 FILES_kernel-image_simone = ""
50
51 SRC_URI_append_ts72xx = " \
52                         file://0001-ts72xx_base.patch;patch=1 \
53                         file://0002-ts72xx_force_machine-id.patch;patch=1 \
54                         file://0003-ep93xx_cpuinfo.patch;patch=1 \
55                         file://0004-ts72xx_sbcinfo.patch;patch=1 \
56                         file://0005-ep93xx_eth.patch;patch=1 \
57                         file://0006-ts72xx_ts_ser1.patch;patch=1 \
58                         file://0007-ts72xx_rs485.patch;patch=1 \
59                         file://0008-ts72xx_ts_eth100.patch;patch=1 \
60                         file://0009-ts7200_cf_ide.patch;patch=1 \
61                         file://0010-ts72xx_pata.patch;patch=1 \
62                         file://0011-ep93xx_pm.patch;patch=1 \
63                         file://0012-ts72xx_gpio_i2c.patch;patch=1 \
64                         file://0013-ts72xx_dio_keypad.patch;patch=1 \
65                         file://0014-ep93xx_spi.patch;patch=1 \
66                         file://0015-ep93xx_cpufreq.patch;patch=1 \
67                         file://0016-ts7200_nor_flash.patch;patch=1 \
68                         "
69
70 # Zaurus family bootloader patches
71 RPSRC = "http://www.rpsys.net/openzaurus/patches/archive"
72 ZAURUSPATCHES = " ${RPSRC}/pxa-linking-bug-r1.patch;patch=1;status=unmergable;name=pxa-linking-bug-r1 "
73 SRC_URI[pxa-linking-bug-r1.md5sum] = "1e2a99787260c3566033e7f41180e2c8"
74 SRC_URI[pxa-linking-bug-r1.sha256sum] = "785d2680022325ad54c1593082dce902f5fee31dae4c1922ba43956b1dcfcd8b"
75
76 # Machine specific patches
77 SRC_URI_append_akita = "${ZAURUSPATCHES}"
78 SRC_URI_append_c7x0 = "${ZAURUSPATCHES}"
79 SRC_URI_append_collie = "${ZAURUSPATCHES}"
80 SRC_URI_append_poodle = "${ZAURUSPATCHES}"
81 SRC_URI_append_spitz = "${ZAURUSPATCHES}"
82 SRC_URI_append_tosa = "${ZAURUSPATCHES}"
83
84 SRC_URI_append_eee701 = " \
85         file://intelfb.patch;patch=1 "