Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[openembedded.git] / recipes / linux / linux_2.6.29.bb
1 require linux.inc
2
3 PR = "r1"
4
5 S = "${WORKDIR}/linux-2.6.29"
6
7 # Mark archs/machines that this kernel supports
8 DEFAULT_PREFERENCE = "-1"
9 DEFAULT_PREFERENCE_boc01 = "1"
10 DEFAULT_PREFERENCE_canyonlands = "1"
11 DEFAULT_PREFERENCE_tosa = "1"
12 DEFAULT_PREFERENCE_vortex86sx = "1"
13
14 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.29.tar.bz2 \
15            file://defconfig"
16
17 SRC_URI_append_boc01 = "\
18         file://boc01.dts \
19         file://001-090114-sqn11x0-usb-hack.patch;patch=1 \
20         file://004-081205-usb.patch;patch=1 \
21         file://005-090226-isl12024.patch;patch=1 \
22         file://007-081217-lm73.patch;patch=1 \
23         file://008-081208-spi.patch;patch=1 \
24         file://011-090115-gpio.patch;patch=1 \
25         file://012-090219-capsense.patch;patch=1 \
26         file://013-090306-lcd.patch;patch=1 \
27         "
28
29 SRC_URI_append_canyonlands = " \
30         file://0001-powerpc-4xx-Add-PPC4xx-PCIe-MSI-support.patch;patch=1 \
31         "
32
33 SRC_URI_append_tosa = " \
34         file://0001-pxa-make-second-argument-of-clk_add_alias-a-name-in.patch;patch=1 \
35         file://0002-spi-pxa2xx-spi-set-default-cs_control-to-null_cs_co.patch;patch=1 \
36         "