sg3-utils: add newer buildable version
[openembedded.git] / recipes / linux / linux_2.6.28.bb
1 require linux.inc
2
3 PR = "r13"
4
5 # Mark archs/machines that this kernel supports
6 DEFAULT_PREFERENCE = "-1"
7
8 DEFAULT_PREFERENCE_at91sam9263ek = "28"
9 DEFAULT_PREFERENCE_ronetix-pm9263 = "29"
10 DEFAULT_PREFERENCE_stb225 = "28"
11 DEFAULT_PREFERENCE_collie = "1"
12 DEFAULT_PREFERENCE_gamecube = "1"
13 DEFAULT_PREFERENCE_wrap = "1"
14 DEFAULT_PREFERENCE_tx27 = "1"
15 DEFAULT_PREFERENCE_nokia900 = "1"
16 DEFAULT_PREFERENCE_mh355 = "1"
17
18 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.28.tar.bz2 \
19            ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${PV}.10.bz2;patch=1 \
20            file://defconfig"
21
22 SRC_URI_append_at91sam9263ek = " \
23            file://linux-2.6.28-at91.patch.bz2;patch=1 \
24            file://linux-2.6.28-exp.patch.bz2;patch=1 "
25
26 SRC_URI_append_ronetix-pm9263 = " \
27            file://linux-2.6.28-at91.patch.bz2;patch=1 \
28            file://linux-2.6.28-exp.patch.bz2;patch=1 \
29            http://download.ronetix.info/sk-eb926x/linux/kernel/2.6.28/003_linux-2.6.28-at91-ronetix-20112009.patch;patch=1 "
30
31 SRC_URI_append_mh355 = " \
32            file://linux-2.6.28-at91.patch.bz2;patch=1 \
33            file://linux-2.6.28-exp.patch.bz2;patch=1 \
34            file://linux-2.6.28.10-at91-mh.patch;patch=1 "
35
36 SRC_URI_append_stb225 = " \
37            file://uImage.patch;patch=1 \
38            file://ebase-fix.patch;patch=1 \
39            file://enable-uart.patch;patch=1 \
40            file://ip3902.patch;patch=1"
41
42 SRC_URI_append_collie = " \
43         file://0001-collie-start-scoop-converton-to-new-api.patch;patch=1 \
44         file://0002-add-locomo_spi-driver.patch;patch=1 \
45         file://0003-enable-cpufreq-for-collie.patch;patch=1 \
46         file://0004-fix-dma-for-SA1100.patch;patch=1 \
47         file://0005-fix-collie-keyboard-bug.patch;patch=1 \
48         file://0006-add-collie-flash-hack.patch;patch=1 \
49         file://0007-hostap-workaround-for-buggy-sa1100-pcmcia-driver.patch;patch=1 \
50         file://0008-fix-collie-suspend-hack.patch;patch=1 \
51         file://0009-add-sa1100-usb-gadget-driver-hack.patch;patch=1 \
52         file://0010-mmc_spi-add-suspend-and-resume-callbacks.patch;patch=1 \
53         file://0011-move-drivers-mfd-.h-to-include-linux-mfd.patch;patch=1 \
54         file://0012-move-ucb1200-ts-driver.patch;patch=1 \
55         file://0013-add-collie-touchscreen-driver.patch;patch=1 \
56         file://0014-collie-locomo-led-change-default-trigger.patch;patch=1 \
57         file://0015-SA1100-make-gpio_to_irq-and-reverse-a-macro.patch;patch=1 \
58         file://0016-add-gpiolib-support-to-ucb1x00.patch;patch=1 \
59         file://0017-collie-convert-to-gpiolib-for-ucb1x00.patch;patch=1 \
60         file://0018-collie-add-battery-driver.patch;patch=1 \
61         file://0019-collie-support-pda_power-driver.patch;patch=1 \
62         file://0020-remove-collie_pm.c.patch;patch=1 \
63         file://0021-mmc-trivial-annotation-of-blocks.patch;patch=1 \
64         file://0022-mmc_block-print-better-error-messages.patch;patch=1 \
65         file://0023-mmc_block-ensure-all-sectors-that-do-not-have-error.patch;patch=1 " 
66
67 SRC_URI_append_tosa = " \
68         file://commit-31c9b28;patch=1 \
69         file://commit-ddfb33c;patch=1 \
70         file://commit-f34ee79;patch=1 \
71         "
72 SRC_URI_append_gamecube = " \
73         file://patch-2.6.28-gc;patch=1 \
74         "
75
76 SRC_URI_append_tx27 = " \
77         file://linux-2.6.28-karo4.diff;patch=1 \
78         "
79
80 SRC_URI_nokia900 = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.28.tar.bz2 \
81                     http://repository.maemo.org/pool/maemo5.0/free/k/kernel/kernel_2.6.28-20094803.3+0m5.diff.gz;patch=1 \
82                     file://defconfig"
83
84 S = "${WORKDIR}/linux-2.6.28/"