sg3-utils: add newer buildable version
[openembedded.git] / recipes / linux / linux_2.6.27.bb
1 require linux.inc
2
3 PR = "r14"
4
5 # Mark archs/machines that this kernel supports
6 DEFAULT_PREFERENCE = "-1"
7 DEFAULT_PREFERENCE_boc01 = "1"
8 DEFAULT_PREFERENCE_progear = "1"
9 DEFAULT_PREFERENCE_simpad = "-1"
10 DEFAULT_PREFERENCE_ts72xx = "1"
11
12 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
13            ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${PV}.45.bz2;patch=1 \
14            file://defconfig "
15
16 SRC_URI_append_boc01 = "\
17         file://boc01.dts \
18         file://001-090114-sqn11x0-usb-hack.patch;patch=1 \
19         file://004-081205-usb.patch;patch=1 \
20         file://005-090226-isl12024.patch;patch=1 \
21         file://007-081217-lm73.patch;patch=1 \
22         file://008-081208-spi.patch;patch=1 \
23         file://011-090115-gpio.patch;patch=1 \
24         file://012-090219-capsense.patch;patch=1 \
25         file://013-090306-lcd.patch;patch=1 \
26         "
27
28 SRC_URI_append_progear = "file://progear-bl.patch;patch=1\
29                           file://progear-ac2.patch;patch=1"
30
31 SRC_URI_append_simpad = "\
32            file://linux-2.6.27-SIMpad-GPIO-MMC-mod.patch;patch=1 \
33            file://linux-2.6.27-SIMpad-battery-old-way-but-also-with-sysfs.patch;patch=1 \
34            file://linux-2.6.27-SIMpad-cs3-simpad.patch;patch=1 \
35            file://linux-2.6.27-SIMpad-mq200.patch;patch=1 \
36            file://linux-2.6.27-SIMpad-pcmcia.patch;patch=1 \
37            file://linux-2.6.27-SIMpad-serial-gpio_keys-and-cs3-ro.patch.v2;patch=1 \
38            file://linux-2.6.27-SIMpad-ucb1x00-switches.patch;patch=1 \
39            file://linux-2.6.27-SIMpad-ucb1x00-ts-supend-and-accuracy.patch;patch=1 \
40            file://linux-2.6.24-SIMpad-hostap_cs-shared-irq.patch;patch=1 \
41            file://linux-2.6.24-SIMpad-orinoco_cs-shared-irq.patch;patch=1 \
42            file://linux-2.6.24-SIMpad-rtc-sa1100.patch;patch=1 \
43            file://connectplus-remove-ide-HACK.patch;patch=1 \
44            "
45
46 SRC_URI_append_ts72xx = "\
47            file://0001-TS72xx-update-memory-map-comments.patch;patch=1 \
48            file://0002-GPIO-fix.patch;patch=1 \
49            file://0003-Debounce-IRQ.patch;patch=1 \
50            file://0004-OHCI-fix.patch;patch=1 \
51            file://0005-Fix-wrong-machine-ID-passed-from-RedBoot.patch;patch=1 \
52            file://0006-Force-the-nF-bit-on.patch;patch=1 \
53            file://0007-Use-CPLD-watchdog-to-reset.patch;patch=1 \
54            file://0008-Fix-UART-clocks.patch;patch=1 \
55            file://0009-CPU-info-and-board-revision.patch;patch=1 \
56            file://0010-GPIO-leds.patch;patch=1 \
57            file://0011-EP93xx-Ethernet-support.patch;patch=1 \
58            file://0012-TS72xx-watchdog.patch;patch=1 \
59            file://0013-TS7200-NOR-physmap-fix.patch;patch=1 \
60            file://0014-TS-7200-8MB-NOR-flash.patch;patch=1 \
61            file://0015-TS-72xx-MAX197-support.patch;patch=1 \
62            file://0016-RS485-common-bits.patch;patch=1 \
63            file://0017-TS-72xx-SBC-proc-info.patch;patch=1 \
64            file://0018-EP93xx-GPIO-I2C.patch;patch=1 \
65            file://0019-EP93xx-SPI-driver.patch;patch=1 \
66            file://0020-TS-72XX-LCD-console-driver.patch;patch=1 \
67            file://0021-EP93xx-GPIO-matrix-keypad.patch;patch=1 \
68            file://0022-TS-72xx-RS485-auto-mode-support.patch;patch=1 \
69            file://0023-Clean-and-invalidate-D-cache-entry.patch;patch=1 \
70            file://0024-PC-104-I-O-and-memory-mappings.patch;patch=1 \
71            file://0025-EP93xx-discontigmem.patch;patch=1 \
72            file://0026-TS72xx-PATA-support.patch;patch=1 \
73            file://0027-TS72xx-TS-SER1-support.patch;patch=1 \
74            file://0028-TS72xx-TS-ETH100.patch;patch=1 \
75            file://0029-EP93xx-Power-Management-Routines.patch;patch=1 \
76            file://0030-EP93xx-CPUfreq-driver.patch;patch=1 \
77            "
78
79 # see http://bugzilla.kernel.org/show_bug.cgi?id=11143
80 do_stage_append() {
81         if [ -f arch/${ARCH}/lib/crtsavres.o ]; then
82                 mkdir -p ${STAGING_KERNEL_DIR}/arch/${ARCH}/lib
83                 cp -a arch/${ARCH}/lib/crtsavres.o ${STAGING_KERNEL_DIR}/arch/${ARCH}/lib/
84         fi
85 }
86