sg3-utils: add newer buildable version
[openembedded.git] / recipes / linux / linux-xxs1500_2.4.21.bb
1 SECTION = "kernel"
2 DESCRIPTION = "Linux kernel for mycable xxs1500"
3 LICENSE = "GPLv2"
4 KV = "2.4.21"
5 PV = "${KV}"
6
7 SRC_URI = "http://mycable.de/xxs1500/cms/index.php?download=linux-2.4.21-20040514.1522.tgz \
8         file://Makefile \
9         file://defconfig-xxs1500 \
10         file://zboot-Makefile-flags.diff;patch=1;pnum=0"
11
12 S = "${WORKDIR}/linux"
13
14 inherit kernel
15
16 COMPATIBLE_MACHINE = "xxs1500"
17
18 PACKAGE_ARCH = "xxs1500"
19 ARCH = "mips"
20 KERNEL_OUTPUT = "arch/mips/zboot/images/xxs1500.flash.srec"
21 KERNEL_IMAGETYPE = "zImage.flash"
22 KERNEL_IMAGEDEST = "tmp"
23
24 do_configure_prepend() {
25         install -m 0644 ${WORKDIR}/defconfig-xxs1500 ${S}/.config
26         cp ${WORKDIR}/Makefile ${S}/arch/mips
27 }
28
29 FILES_kernel += " /tmp"