Merge branch 'org.openembedded.dev' of ssh+git://git@git.openembedded.net/openembedde...
[openembedded.git] / recipes / linux / linux-xilinx-slab_git.bb
1 #Kernel for the xilinx-ml403 board using SecretLabs git tree
2 # Copyright (C) 2007, Stelios Koroneos - Digital OPSiS, All Rights Reserved
3 # Released under the MIT license (see packages/COPYING)
4 SECTION = "kernel"
5 DESCRIPTION = "Linux kernel for Xilinx ML403 Virtex 4 fpga board"
6 LICENSE = "GPLv2"
7
8 SRCREV = "d7ed933b578d9c4dec0e23a5a6f78c464b31c47c"
9
10 PR = "r3"
11 PV = "2.6.25+2.6.26+${PR}+gitr${SRCREV}"
12 PE = "1"
13
14 COMPATIBLE_MACHINE = "xilinx-ml403"
15
16 #inherit kernel xilinx-bsp
17 inherit kernel
18
19 S = "${WORKDIR}/git"
20
21
22 FILES_kernel-image = "/boot/zImage.elf"
23
24 export OS = "Linux"
25 ARCH = "ppc"
26 KERNEL_IMAGETYPE = "zImage"
27 KERNEL_OUTPUT = "arch/ppc/boot/images/zImage.elf"
28
29 SRC_URI = "\
30            git://git.secretlab.ca/git/linux-2.6-virtex.git;protocol=git \
31           "
32
33 do_configure() {
34
35                 make ARCH=${ARCH} ml403_defconfig
36 }
37
38 do_deploy() {
39         install -d ${DEPLOY_DIR_IMAGE}
40         install -m 0644 arch/${ARCH}/boot/images/${KERNEL_IMAGETYPE}.elf \
41                  ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME}
42 }
43
44 #seems like 2.6.21 kernel images have moved (or is this only for the Denx kernel ?)
45 #so we need to copy the kernel image where kernel.bbclass expects it to be
46 #do_install_prepend() {
47 #        install -m 0644 arch/${ARCH}/boot/images/${KERNEL_IMAGETYPE}.elf \
48 #                        arch/${ARCH}/boot/${KERNEL_IMAGETYPE}
49 #}