sg3-utils: add newer buildable version
[openembedded.git] / recipes / linux / linux-x86_2.6.20.bb
1 DESCRIPTION = "Linux Kernel for x86 compatible machines"
2 SECTION = "kernel"
3 LICENSE = "GPLv2"
4 PR = "r5"
5
6 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 " 
7
8 SRC_URI_append_x86 = "file://i486-defconfig"
9 SRC_URI_append_i586 = "file://i586-defconfig"
10 SRC_URI_append_i686 = "file://i686-defconfig"
11
12 S = "${WORKDIR}/linux-${PV}"
13
14 KERNEL_IMAGETYPE ?= "bzImage"
15
16 inherit kernel
17
18 COMPATIBLE_HOST = "i.86.*-linux"
19
20 do_configure_prepend_x86() {
21         install -m 0644 ${WORKDIR}/i486-defconfig ${S}/.config
22 }
23
24 do_configure_prepend_i586-generic() {
25         install -m 0644 ${WORKDIR}/i586-defconfig ${S}/.config
26 }
27
28 do_configure_prepend_i686() {
29         install -m 0644 ${WORKDIR}/i686-defconfig ${S}/.config
30 }