sg3-utils: add newer buildable version
[openembedded.git] / recipes / linux / linux-tornado-omap2_2.6.16.16.bb
1 DESCRIPTION = "Linux kernel for HTC Tornado/Typhoon/Hurricane phones."
2 SECTION = "kernel"
3 LICENSE = "GPLv2"
4 PR = "r1"
5
6 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.16.tar.bz2 \
7            http://www.muru.com/linux/omap/patches/old/patch-2.6.16-omap2.bz2;patch=1 \
8            file://linux-2.6.16.16.patch;patch=1 \
9            file://tornado-20070320.patch;patch=1 \
10            file://defconfig"
11
12 S = "${WORKDIR}/linux-2.6.16"
13
14 inherit kernel
15
16 COMPATIBLE_MACHINE = "htctornado"
17
18 do_configure() {
19
20         rm -f ${S}/.config
21
22         if [ ! -e ${WORKDIR}/defconfig ]; then
23                 die "No default configuration for ${MACHINE} available."
24         fi
25
26
27         if [ "${TARGET_OS}" == "linux-gnueabi" -o  "${TARGET_OS}" == "linux-uclibceabi" ]; then
28                 echo "CONFIG_AEABI=y"                   >> ${S}/.config
29                 echo "CONFIG_OABI_COMPAT=y"             >> ${S}/.config
30         else
31                 echo "# CONFIG_AEABI is not set"        >> ${S}/.config
32                 echo "# CONFIG_OABI_COMPAT is not set"  >> ${S}/.config
33         fi
34
35         sed     -e '/CONFIG_AEABI/d' \
36                 -e '/CONFIG_OABI_COMPAT=/d' \
37                 '${WORKDIR}/defconfig' >>'${S}/.config'
38
39         yes '' | oe_runmake oldconfig
40
41 }