sg3-utils: add newer buildable version
[openembedded.git] / recipes / linux / linux-titan-sh4_2.6.21.bb
1 SECTION = "kernel"
2 DESCRIPTION = "Linux kernel for SH4 based TITAN (NP51R/LinkGear Series 100) router appliance"
3 LICENSE = "GPLv2"
4 PR = "r2"
5
6 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
7            file://titan-flash.patch;patch=1 \
8            file://titan-pcibios-scan-update.patch;patch=1 \
9            file://no-mm-mutex.patch;patch=1 \
10            file://linux-2.6-limits.patch;patch=1 \
11            file://linux-sh-__sdivsi3_i4i.patch;patch=1 \
12            file://titan-config"
13 S = "${WORKDIR}/linux-${PV}"
14
15 COMPATIBLE_HOST = 'sh4.*-linux'
16 COMPATIBLE_MACHINE = "titan"
17
18 inherit kernel
19
20 ARCH = "sh"
21 KERNEL_OUTPUT = "arch/${ARCH}/boot/${KERNEL_IMAGETYPE}"
22
23 #
24 # Use an updated defconfig which includes the flash driver
25 # The flash driver quality doesn't allow it to be a part of the main kernel
26 #
27 do_configure_prepend() {
28         install -m 0644 ${WORKDIR}/titan-config ${S}/arch/sh/configs/titan_defconfig
29         yes '' | oe_runmake titan_defconfig
30 }