sg3-utils: add newer buildable version
[openembedded.git] / recipes / linux / linux-sun4cdm_2.4.26.bb
1 SECTION = "kernel"
2 DESCRIPTION = "Linux kernel for sparc32/sun4c"
3 LICENSE = "GPLv2"
4 PR = "r0"
5 DEPENDS += "elftoaout-native"
6
7 KERNEL_CCSUFFIX = "-3.3.4"
8
9 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.4/linux-${PV}.tar.bz2 \
10            file://defconfig"
11 S = "${WORKDIR}/linux-${PV}"
12
13 COMPATIBLE_HOST = 'sparc.*-linux'
14
15 inherit kernel
16
17 ARCH = "sparc"
18 KERNEL_IMAGETYPE = "vmlinux"
19 KERNEL_OUTPUT = "vmlinux"
20
21 do_configure_prepend() {
22         install -m 0644 ${WORKDIR}/defconfig ${S}/.config
23 }
24
25 do_deploy() {
26         install -d ${DEPLOY_DIR_IMAGE}
27         elftoaout -o ${DEPLOY_DIR_IMAGE}/linux-aout-${DATETIME} ${KERNEL_IMAGETYPE}
28 }