sg3-utils: add newer buildable version
[openembedded.git] / recipes / linux / linux-smdk2443_2.6.20+git.bb
1 DESCRIPTION = "Linux Kernel for smdk2443 compatible machines"
2 SECTION = "kernel"
3 LICENSE = "GPLv2"
4 DEPENDS += "u-boot-mkimage-openmoko-native"
5
6 PR = "r1"
7
8 GGSRC = "http://www.xora.org.uk/oe/patches/"
9
10 SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git;protocol=git;tag=v2.6.21-rc5 \
11            file://0020-Add-ASoC-S3C24xx-platform-support.patch;patch=1 \
12            file://0021-Add-Neo1973-ASoC-support.patch;patch=1 \
13            file://0022-Add-initial-ASoC-SMDK2440-support.patch;patch=1 \
14            file://0023-Add-ASoC-SMDK2440-support-for-WM8956-codec.patch;patch=1 \
15            file://0034-Export-ac97_dai.patch;patch=1 \
16            file://0036-Move-s3c24xx_i2s_dai-and-add-dma_size.patch;patch=1 \
17            file://0037-Use-dma_size-parameter-and-fix-buffdone-oops.patch;patch=1 \
18            file://0038-Add-smdk2443-s3c2443-ac97-and-wm9710-support.patch;patch=1 \
19            file://asoc-mainline.patch;patch=1 \
20            file://defconfig-smdk2443"
21
22 S = "${WORKDIR}/git"
23
24 inherit kernel
25
26 COMPATIBLE_HOST = "arm.*-linux"
27 COMPATIBLE_MACHINE = "smdk2443"
28
29 do_configure() {
30         install ${WORKDIR}/defconfig-smdk2443 ${S}/.config
31         oe_runmake oldconfig
32 }
33
34 do_deploy_append() {
35         ${OBJCOPY} -O binary -R .note -R .comment -S vmlinux linux.bin
36         rm -f linux.bin.gz
37         gzip -9 linux.bin
38         uboot-mkimage -A arm -O linux -T kernel -C gzip -a 30008000 -e 30008000 -n "smdk2443 kernel" -d linux.bin.gz ${DEPLOY_DIR_IMAGE}/uImage-${PV}-${MACHINE}-${DATETIME}.bin
39         rm -f linux.bin.gz
40 }
41
42 KERNEL_RELEASE = "2.6.21-rc5"