sg3-utils: add newer buildable version
[openembedded.git] / recipes / linux / linux-sequoia_2.6.21.bb
1 # Copyright (C) 2007, Stelios Koroneos - Digital OPSiS, All Rights Reserved
2 # Released under the MIT license (see packages/COPYING)
3 SECTION = "kernel"
4 DESCRIPTION = "Linux kernel for AMCC's Sequoia dev board"
5 LICENSE = "GPLv2"
6 PR = "r0"
7 #DEPENDS = "u-boot"
8
9 COMPATIBLE_MACHINE = "sequoia"
10
11 #DENX git kernel
12 #Same as in AMCC's sequoia dev kit
13 SRC_URI ="git://www.denx.de/git/linux-2.6-denx.git;protocol=git;tag=78157a82fa20719f7e3307307755888e9af2c0e9 \
14           file://sequoia_defconfig "
15
16
17 S = "${WORKDIR}/git"
18
19 inherit kernel
20
21 export ARCH="ppc"
22
23 KERNEL_IMAGETYPE = "zImage.elf"
24
25 do_configure() {
26                 install -m 644 ${WORKDIR}/sequoia_defconfig ${S}/.config
27                 make ARCH=${ARCH} oldconfig
28 }
29
30 do_stage_append () {
31 #need ppc platforms includes + friends in order for external kernel modules to compile as headers a$
32
33        install -d ${STAGING_KERNEL_DIR}/arch/
34        cp -pPR arch/ppc ${STAGING_KERNEL_DIR}/arch/
35        cp -pPR arch/powerpc ${STAGING_KERNEL_DIR}/arch/
36
37        install -d ${STAGING_KERNEL_DIR}/include/asm
38        cp -pPR include/asm-powerpc ${STAGING_KERNEL_DIR}/include/
39        cp -pPR include/asm-ppc ${STAGING_KERNEL_DIR}/include/
40 }
41
42 #seems like 2.6.21 kernel images have moved (or is this only for the Denx kernel ?)
43 #so we need to copy the kernel image where kernel.bbclass expects it to be
44 do_install_prepend() {
45         install -m 0644 arch/${ARCH}/boot/images/${KERNEL_IMAGETYPE} \
46                         arch/${ARCH}/boot/${KERNEL_IMAGETYPE}
47 }