sg3-utils: add newer buildable version
[openembedded.git] / recipes / linux / linux-rt_2.6.24.bb
1 require linux.inc
2
3 # Mark archs/machines that this kernel supports
4 DEFAULT_PREFERENCE = "-1"
5 DEFAULT_PREFERENCE_mpc8313e-rdb = "1"
6 DEFAULT_PREFERENCE_mpc8315e-rdb = "1"
7
8 PR = "r9"
9
10 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.24.tar.bz2 \
11            ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-2.6.24.7.bz2;patch=1;p=1 \
12            ${KERNELORG_MIRROR}/pub/linux/kernel/projects/rt/patch-2.6.24.7-rt27.bz2;patch=1;p=1 \
13            file://squashfs-lzma-2.6.24.patch;patch=1 \
14            file://powerpc-clockres.patch;patch=1 \
15            file://defconfig"
16
17 #           file://sysctl_missing_include.patch;patch=1 \
18
19 S = "${WORKDIR}/linux-2.6.24"
20
21 SRC_URI_append_mpc8313e-rdb = " \
22            file://leds-cpu-activity.patch;patch=1 \
23            file://leds-cpu-activity-powerpc.patch;patch=1 \
24            file://mpc8313e-rdb-leds.patch;patch=1"
25 #       file://mpc831x-nand.patch;patch=1 \
26 #       file://mpc8313e-rdb-rtc.patch;patch=1 "
27
28
29 # override the device tree source file from linux.inc, as the patches below
30 # introduce new variants. -- Leon Woestenberg
31 KERNEL_DEVICETREE_mpc8315e-rdb = "arch/${ARCH}/boot/dts/mpc8315erdb_default.dts"
32
33 # Patch series taken from MPC8315ERDB_20080627-ltib.iso, available as-is from
34 # Freescale's web site. Patches also available at www.bitshrine.org, which I
35 # use here. -- Leon Woestenberg <leon@sidebranch.com>
36
37 SRC_URI_mpc8315e-rdb = " \
38 ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.24.tar.bz2 \
39 ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-2.6.24.3.bz2;patch=1;p=1 \
40 ${KERNELORG_MIRROR}/pub/linux/kernel/projects/rt/older/patch-2.6.24.3-rt3.bz2;patch=1;p=1 \
41 file://squashfs-lzma-2.6.24.patch;patch=1 \
42 file://powerpc-clockres.patch;patch=1 \
43 http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-platform-support.patch;patch=1 \
44 http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-add-all-interrupts.patch;patch=1 \
45 http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-Realtek-821x-phy.patch;patch=1 \
46 http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-fix-gianfar.patch;patch=1 \
47 http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-Gianfar-buffer-recycling.patch;patch=1 \
48 http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-Gianfar-performance.patch;patch=1 \
49 http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-sata-support.patch;patch=1 \
50 http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-fsl-serdes-support.patch;patch=1 \
51 http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-pcie-INTx-support.patch;patch=1 \
52 http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-ipic-msi.patch;patch=1 \ 
53 http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-usb-support.patch;patch=1 \
54 http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-power-management.patch;patch=1 \
55 http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-usb-power-mangement.patch;patch=1 \
56 http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-NAND-flash.patch;patch=1 \
57 http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-elbc-jffs2-on-nand.patch;patch=1 \
58 http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-Codewarrior-kernel-debug.patch;patch=1 \
59 http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-otg.patch;patch=1 \
60 http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC831x-LFC.patch;patch=1 \
61 http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-TDM.patch;patch=1 \
62 http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-tdm-test-modules.patch;patch=1 \
63 http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-spi-for-tdm-module.patch;patch=1 \
64 http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-port-mutiplier-in-sata.patch;patch=1 \ 
65 http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-performance-monitor.patch;patch=1 \
66 http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-ieee-1588.patch;patch=1 \
67 http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-DTS.patch;patch=1 \
68 http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-sata-pm.patch;patch=1 \
69 http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-fix-large-file-transfer.patch;patch=1 \
70 http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-MPC8315ERDB-default-configuration.patch;patch=1 \
71 file://defconfig \
72 "
73
74 # Last 5 patches in the series, for crypto stuff. The 2nd of these is created
75 # against crypto/ocf/ and thus needs a proper rebase against the base dir.
76 # This remains a todo. -- Leon Woestenberg.
77 #SRC_URI_append_mpc8315e-rdb = " \
78 #http://www.bitshrine.org/gpp/ocf-linux-26-20071215.patch.gz;patch=1 \
79 #http://www.bitshrine.org/gpp/ocf-linux-20071215-20080427.diff;patch=1 \
80 #http://www.bitshrine.org/gpp/linux-fsl-2.6.24-OCF-fsl_soc-2.patch;patch=1 \
81 #http://www.bitshrine.org/gpp/linux-2.6.24-Openswan-2.4.12.patch;patch=1 \
82 #http://www.bitshrine.org/gpp/linux-fsl-2.6.24.3-openswan-sysctl.patch;patch=1 \
83 #"