sg3-utils: add newer buildable version
[openembedded.git] / recipes / linux / linux-openmoko-shr-devel_git.bb
1 require linux.inc
2 require linux-openmoko.inc
3
4 DESCRIPTION_${PN} = "Linux ${KERNEL_VERSION} kernel for the Openmoko Neo GSM Smartphones"
5
6 KERNEL_RELEASE = "2.6.29"
7 KERNEL_VERSION = "2.6.29-rc3"
8
9 SRCREV = "a15608f241a40b41fed5bffe511355c2067c4e88"
10 OMV = "oe11"
11 PV = "${KERNEL_RELEASE}-${OMV}+gitr${SRCREV}"
12 PR = "r8"
13
14 SRC_URI = "\
15   git://git.openmoko.org/git/kernel.git;protocol=git;branch=andy-tracking \
16   file://fix-install.patch;patch=1 \
17   file://0007-Enable-UBI-UBIFS.patch;patch=1 \
18 "
19 S = "${WORKDIR}/git"
20
21 CONFIG_NAME_om-gta01 = "gta01_moredrivers_defconfig"
22 CONFIG_NAME_om-gta02 = "gta02_packaging_defconfig"
23
24 do_configure_prepend() { 
25         install -m 644 ./arch/arm/configs/${CONFIG_NAME} ${WORKDIR}/defconfig-oe
26 }