sg3-utils: add newer buildable version
[openembedded.git] / recipes / linux / linux-openmoko-2.6.32_git.bb
1 require linux.inc
2 require linux-openmoko.inc
3
4 DESCRIPTION_${PN} = "Linux ${KERNEL_RELEASE} kernel for the Openmoko Neo GSM Smartphones"
5
6 KERNEL_RELEASE="2.6.32.11"
7
8 SRCREV = "14be1091928fcce66812a85129768fb253b36420"
9 OEV = "oe1"
10 PV = "${KERNEL_RELEASE}-${OEV}+gitr${SRCREV}"
11 PR = "r5"
12
13 SRC_URI = "\
14   git://git.openmoko.org/git/kernel.git;protocol=git;branch=om-gta02-2.6.32 \
15   file://0001-Revert-s3cmci-initialize-default-platform-data-no_wp.patch;patch=1 \
16 # latest stable patch for ubi fix 943e167cb3e8fb191894bde8a4a75db78531a7c8
17   ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${KERNEL_RELEASE}.bz2;patch=1;name=stablepatch \
18   file://defconfig \
19 # build fix
20   file://0001-wm8753-fix-build-with-gcc-4.4.2-which-works-ok-with-.patch;patch=1 \
21 # patches from Weiss's gdrm-2.6.32 branch
22   file://0002-DRM-for-platform-devices.patch;patch=1 \
23   file://0003-Glamo-DRM-and-KMS-driver.patch;patch=1 \
24   file://0004-Work-on-Glamo-core-for-DRM.patch;patch=1 \
25   file://0005-Add-JBT6k74-hook-for-use-by-KMS.patch;patch=1 \
26   file://0006-glamo-drm-use-dev_set_drvdata-instead-of-setting-dri.patch;patch=1 \
27   file://0007-glamo-drm-select-DRM_KMS_HELPER-for-crtc-functions.patch;patch=1 \
28   file://0008-Fix-crash-when-reading-Glamo-registers-via-sysfs.patch;patch=1 \
29   file://0009-A-couple-of-GEM-refcounting-fixes.patch;patch=1 \
30   file://0010-Simplify-the-JBT6k74-driver.patch;patch=1 \
31   file://0011-Don-t-choke-if-userspace-provides-a-pixel-clock-valu.patch;patch=1 \
32   file://0012-Report-all-FB-modes-given-by-the-lower-levels.patch;patch=1 \
33   file://0013-Change-connector-type-to-LVDS.patch;patch=1 \
34   file://0014-Clean-up-JBT-hooks-and-allow-resolution-switching.patch;patch=1 \
35   file://0015-ar6000-send-userspace-an-event-on-disconnection.patch;patch=1 \
36   file://0016-Enable-display-before-trying-to-set-mode-or-base.patch;patch=1 \
37 "
38
39 SRC_URI[stablepatch.md5sum] = "855c248334a71ef5ca3d8cb89d51334f"
40 SRC_URI[stablepatch.sha256sum] = "edb26ff62b2f95b0d6e5c434d777af2815600a990f1c7c5d2c7faad9b4e4bc2b"
41
42
43 S = "${WORKDIR}/git"
44
45 do_configure_prepend() { 
46         install -m 644 ${WORKDIR}/defconfig ${WORKDIR}/defconfig-oe
47 }