sg3-utils: add newer buildable version
[openembedded.git] / recipes / linux / linux-openmoko-2.6.31_git.bb
1 require linux.inc
2 require linux-openmoko.inc
3
4 DESCRIPTION_${PN} = "Linux ${KERNEL_VERSION} kernel for the Openmoko Neo GSM Smartphones"
5
6 KERNEL_RELEASE = "2.6.31"
7 KERNEL_VERSION = "${KERNEL_RELEASE}"
8
9 SRCREV = "dd32737aa524e09c1d141a0e735dd58674552244"
10 OEV = "oe1"
11 PV = "${KERNEL_RELEASE}-${OEV}+gitr${SRCREV}"
12 PR = "r6"
13
14 SRC_URI = "\
15   git://git.openmoko.org/git/kernel.git;protocol=git;branch=om-2.6.31 \
16 # build fix
17   file://0001-wm8753-fix-build-with-gcc-4.4.2-which-works-ok-with-.patch;patch=1 \
18 # patches from Weiss's gdrm-2.6.31 branch
19   file://0001-DRM-for-platform-devices.patch;patch=1 \
20   file://0002-Glamo-DRM-and-KMS-driver.patch;patch=1 \
21   file://0003-Work-on-Glamo-core-for-DRM.patch;patch=1 \
22   file://0004-Add-JBT6k74-hook-for-use-by-KMS.patch;patch=1 \
23 # enable UBI+DRM+NFS+INOTIFY_USER
24   file://0004-gta02_defconfig-Enable-UBI-support.patch;patch=1 \
25   file://0005-gta02_defconfig-Enable-UBI-debug.patch;patch=1 \
26   file://0001-gta02_defconfig-Enable-GLAMO_DRM.patch;patch=1 \
27   file://0006-gta02-defconfig-enable-NFS-and-INOTIFY_USER.patch;patch=1 \
28   file://0007-gta02_defconfig-disable-LEDS_GTA02_VIBRATOR.patch;patch=1 \
29 "
30
31 S = "${WORKDIR}/git"
32
33 CONFIG_NAME_om-gta01 = "gta01_defconfig"
34 CONFIG_NAME_om-gta02 = "gta02_defconfig"
35
36 do_configure_prepend() { 
37         install -m 644 ./arch/arm/configs/${CONFIG_NAME} ${WORKDIR}/defconfig-oe
38 }