sg3-utils: add newer buildable version
[openembedded.git] / recipes / linux / linux-openmoko-2.6.28_git.bb
1 require linux.inc
2 require linux-openmoko.inc
3
4 DESCRIPTION_${PN} = "Linux ${KERNEL_RELEASE} kernel for the Openmoko Neo GSM Smartphones"
5
6 KERNEL_RELEASE = "2.6.28"
7 KERNEL_VERSION = "${KERNEL_RELEASE}"
8
9 SRCREV = "8c65792a5c83c76d662a617a7c4e1ae8104bb6a5"
10 OEV = "oe2"
11 PV = "${KERNEL_RELEASE}-${OEV}+gitr${SRCREV}"
12 PR = "r0"
13
14 SRC_URI = "\
15   git://git.openmoko.org/git/kernel.git;protocol=git;branch=stable \
16   file://defconfig-oe.patch \
17 "
18 S = "${WORKDIR}/git"
19
20 CONFIG_NAME_om-gta01 = "gta01_moredrivers_defconfig"
21 CONFIG_NAME_om-gta02 = "gta02_packaging_defconfig"
22
23 do_configure_prepend() {
24         install -m 644 ./arch/arm/configs/${CONFIG_NAME} ${WORKDIR}/defconfig-oe
25         cat ${WORKDIR}/defconfig-oe.patch | patch -p0 -d ${WORKDIR}
26 }
27
28