sg3-utils: add newer buildable version
[openembedded.git] / recipes / linux / linux-omap_git.bb
1 require linux.inc
2
3 DESCRIPTION = "Linux kernel for OMAP processors"
4 KERNEL_IMAGETYPE = "uImage"
5
6 COMPATIBLE_MACHINE = "omap5912osk|omap1710h3|omap2430sdp|omap2420h4|beagleboard|omap3evm|omap3-pandora|overo|omapzoom|omapzoom2|omap4430-sdp"
7
8 DEFAULT_PREFERENCE = "-1"
9
10 SRCREV = "945044d157dd63c6af0f2ed40a5346382af94eb4"
11
12 FILESPATHPKG_prepend = "linux-omap-2.6.31:"
13
14 # The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc
15 #PV = "2.6.30+2.6.31-rc8+gitr${SRCREV}"
16 PV = "2.6.31"
17
18 SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/tmlind/linux-omap-2.6.git;protocol=git \
19            file://defconfig"
20
21 SRC_URI_append = " \
22                   file://ehci.patch;patch=1 \
23                   file://0001-implement-TIF_RESTORE_SIGMASK-support-and-enable-the.patch;patch=1 \
24                   file://cache/l1cache-shift.patch;patch=1 \
25                   file://cache/copy-page-tweak.patch;patch=1 \
26                   file://dss2/0001-OMAP2-Add-funcs-for-writing-SMS_ROT_-registers.patch;patch=1 \
27                   file://dss2/0002-OMAP-OMAPFB-split-omapfb.h.patch;patch=1 \
28                   file://dss2/0003-OMAP-OMAPFB-add-omapdss-device.patch;patch=1 \
29                   file://dss2/0004-OMAP-Add-VRAM-manager.patch;patch=1 \
30                   file://dss2/0005-OMAP-Add-support-for-VRFB-rotation-engine.patch;patch=1 \
31                   file://dss2/0006-OMAP-DSS2-Documentation-for-DSS2.patch;patch=1 \
32                   file://dss2/0007-OMAP-DSS2-Display-Subsystem-Driver-core.patch;patch=1 \
33                   file://dss2/0008-OMAP-DSS2-Add-more-core-files.patch;patch=1 \
34                   file://dss2/0009-OMAP-DSS2-DISPC.patch;patch=1 \
35                   file://dss2/0010-OMAP-DSS2-DPI-driver.patch;patch=1 \
36                   file://dss2/0011-OMAP-DSS2-Video-encoder-driver.patch;patch=1 \
37                   file://dss2/0012-OMAP-DSS2-RFBI-driver.patch;patch=1 \
38                   file://dss2/0013-OMAP-DSS2-SDI-driver.patch;patch=1 \
39                   file://dss2/0014-OMAP-DSS2-DSI-driver.patch;patch=1 \
40                   file://dss2/0015-OMAP-DSS2-omapfb-driver.patch;patch=1 \
41                   file://dss2/0016-OMAP-DSS2-Add-DPI-panel-drivers.patch;patch=1 \
42                   file://dss2/0017-OMAP-DSS2-Taal-DSI-command-mode-panel-driver.patch;patch=1 \
43                   file://dss2/0001-OMAP3-Enable-DSS2-for-OMAP3EVM-board.patch;patch=1 \
44                   file://dss2/0002-V4L2-Added-New-V4L2-CIDs-for-omap-devices-V4L2-IOCT.patch;patch=1 \
45                   file://dss2/0003-V4L2-Updated-v4l2_common-for-new-V4L2-CIDs.patch;patch=1 \
46                   file://dss2/0004-OMAP2-3-V4L2-Add-support-for-OMAP2-3-V4L2-driver-on.patch;patch=1 \
47                   file://expansion-boards/tincantools-zippy.patch;patch=1 \
48                   file://madc/madc-driver.patch;patch=1 \
49                   file://madc/madc.patch;patch=1 \
50                   file://arch-has-holes.diff;patch=1 \
51                   file://usb/0001-musb-fix-put_device-call-sequence.patch;patch=1 \
52                   file://usb/0008-omap3-Add-CHIP_GE_OMAP3430ES3-for-HSUSB.patch;patch=1 \
53                   file://usb/0011-musb-fix-musb-gadget_driver-NULL-bug.patch;patch=1 \
54                   file://usb/0012-musb-Add-back-old-musb-procfs-file.patch;patch=1 \
55                   file://usb/0013-musb-Remove-USB_SUSPEND-auto-select-with-OTG.patch;patch=1 \
56                   file://usb/0014-musb-disable-PING-on-status-phase-of-control-transf.patch;patch=1 \
57                   file://usb/0015-musb-Add-context-save-and-restore-support.patch;patch=1 \
58                   file://usb/0016-usb-update-defconfig.patch;patch=1 \
59                   file://usb/0001-ARM-OMAP-Fix-beagleboard-EHCI-setup.patch;patch=1 \
60                   file://modedb-hd720.patch;patch=1 \
61                   file://dss2/beagle-dss2-support.patch;patch=1 \
62                   file://fix-serial.eml;patch=1 \
63                   file://fix-omap4.diff;patch=1 \
64 "
65
66 SRC_URI_append_beagleboard = " file://logo_linux_clut224.ppm \
67 "
68
69 S = "${WORKDIR}/git"
70
71 module_autoload_ohci-hcd_omap5912osk = "ohci-hcd"
72