sg3-utils: add newer buildable version
[openembedded.git] / recipes / linux / linux-omap_2.6.32.bb
1 require linux.inc
2
3 DESCRIPTION = "Linux kernel for OMAP processors"
4 KERNEL_IMAGETYPE = "uImage"
5
6 COMPATIBLE_MACHINE = "omap5912osk|omap1710h3|omap2430sdp|omap2420h4|beagleboard|omap3evm|omap3-pandora|overo|omapzoom|omapzoom2|omap4430-sdp|cm-t35"
7
8 DEFAULT_PREFERENCE = "-1"
9 DEFAULT_PREFERENCE_cm-t35 = "1"
10
11 SRCREV = "89c9eaeb92c97348dcabd6cb377b646c00855f6a"
12
13 # The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc
14 PV = "2.6.32"
15
16 SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/tmlind/linux-omap-2.6.git;protocol=git \
17            file://defconfig"
18
19 SRC_URI_append = " \
20 file://usb/ehci.patch;patch=1 \
21 file://usb/ehci-omap.c-mach-to-plat.diff;patch=1 \
22 file://cm-t35/0001-omap3-cm-t35-add-mux-initialization.patch;patch=1 \
23 file://cm-t35/0001-OMAP-DSS2-add-Toppoly-TDO35S-panel.patch;patch=1 \
24 file://cm-t35/0002-omap3-cm-t35-add-DSS2-display-support.patch;patch=1 \
25 file://cm-t35/0003-omap3-cm-t35-update-defconfig-for-DSS2.patch;patch=1 \
26 file://cm-t35/0004-omap3-cm-t35-add-cm-t35-mux-configs.patch;patch=1 \
27 file://cm-t35/0006-omap3-cm-t35-update-defconfig.patch;patch=1 \
28 file://cm-t35/0001-backlight-tdo24m-ensure-chip-select-changes-between-.patch;patch=1 \
29 file://0001-ARM-OMAP-Overo-Add-support-for-second-ethernet-po.patch;patch=1 \
30 file://0003-drivers-net-smsc911x-return-ENODEV-if-device-is-n.patch;patch=1 \
31 file://0004-drivers-input-touchscreen-ads7846-return-ENODEV.patch;patch=1 \
32 file://0005-ARM-OMAP-add-support-for-TCT-Zippy-to-Beagle-board.patch;patch=1 \
33 file://0006-ARM-OMAP-Make-beagle-u-boot-partition-writable.patch;patch=1 \
34 file://0007-ASoC-enable-audio-capture-by-default-for-twl4030.patch;patch=1 \
35 file://0009-MTD-NAND-omap2-proper-fix-for-subpage-read-ECC-error.patch;patch=1 \
36 file://madc/0009-drivers-mfd-add-twl4030-madc-driver.patch;patch=1 \
37 file://madc/0010-ARM-OMAP-Add-twl4030-madc-support-to-Overo.patch;patch=1 \
38 file://madc/0011-ARM-OMAP-Add-twl4030-madc-support-to-Beagle.patch;patch=1 \
39 file://madc/0013-ARM-OMAP-Add-missing-twl4030-madc-header-file.patch;patch=1 \
40 file://dss2/0012-OMAP-DSS2-Add-support-for-LG-Philips-LB035Q02-pane.patch;patch=1 \
41 file://dss2/0014-OMAP-DSS-Add-DSS2-support-for-Overo.patch;patch=1 \
42 file://dss2/0015-OMAP-DSS-Add-DSS2-support-for-Beagle.patch;patch=1 \
43 file://dss2/0016-video-add-timings-for-hd720.patch;patch=1 \
44 file://holes.patch;patch=1 \
45 "
46
47 SRC_URI_append_beagleboard = " file://logo_linux_clut224.ppm \
48 "
49
50 S = "${WORKDIR}/git"
51
52 module_autoload_ohci-hcd_omap5912osk = "ohci-hcd"
53