sg3-utils: add newer buildable version
[openembedded.git] / recipes / linux / linux-omap-psp_2.6.29.bb
1 require linux.inc
2
3 DESCRIPTION = "Linux kernel for OMAP processors"
4 KERNEL_IMAGETYPE = "uImage"
5
6 COMPATIBLE_MACHINE = "omap3evm|am3517-evm"
7
8 SRCREV = "9abb6eb717acbca192ab251a056e3a66b2b47884"
9
10 # The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc
11 PR_append = "+gitr${SRCREV}"
12
13 SRC_URI = "git://arago-project.org/git/people/sriram/ti-psp-omap.git;protocol=git;branch=int_030000_build3 \
14            file://0001-implement-TIF_RESTORE_SIGMASK-support-and-enable-the.patch;patch=1 \
15            file://defconfig"
16
17 S = "${WORKDIR}/git"
18
19 SRC_URI_append_am3517-evm = " \
20         file://shiva-bits.diff;patch=1 \
21         file://shiva-ehci.diff;patch=1 \
22 "
23
24 SRC_URI_append_omap3evm = " \
25         file://fix-twl-merge-damage.diff;patch=1 \
26         file://fix-section-mismatch.diff;patch=1 \
27         file://no-3517-hack.diff;patch=1 \
28 "
29
30 do_install_append() {
31         install -d ${D}/boot
32         install -m 0644 Documentation/arm/OMAP/DSS ${D}/boot/
33 }
34
35 PACKAGES =+ "omap-dss-doc"
36 FILES_omap-dss-doc = "/boot/DSS"
37
38 module_autoload_ohci-hcd_omap5912osk = "ohci-hcd"
39
40