sg3-utils: add newer buildable version
[openembedded.git] / recipes / linux / linux-linkstationppc_2.6.28.4.bb
1 DESCRIPTION = "Linux Kernel for the Buffalo Linkstation HD/HG"
2 SECTION = "kernel"
3 LICENSE = "GPLv2"
4 PR = "r0"
5
6 DEPENDS = "dtc-native u-boot-mkimage-native"
7 COMPATIBLE_MACHINE = "(lsppchd|lsppchg)"
8
9 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.28.tar.bz2 \
10            ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${PV}.gz;patch=1 \
11            file://fw-and-powerpc-install.patch;patch=1 \
12            file://defconfig \
13                "
14 S = "${WORKDIR}/linux-2.6.28"
15
16 require linux.inc
17
18 export ARCH="powerpc"
19
20 do_configure() {
21         install -m 0644 ${WORKDIR}/defconfig ${S}/.config
22         ARCH=${ARCH} oe_runmake oldconfig
23 }