sg3-utils: add newer buildable version
[openembedded.git] / recipes / linux / linux-jlime-jornada7xx_2.6.19rc6.bb
1 SECTION = "kernel"
2 DESCRIPTION = "JLime Linux kernel for Arm based Jornada 7xx"
3 LICENSE = "GPLv2"
4 PR = "r0"
5
6 COMPATIBLE_HOST = "arm.*-linux"
7 COMPATIBLE_MACHINE = "jornada7xx"
8
9 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.18.tar.gz \
10            ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/testing/v2.6.19/patch-2.6.19-rc6.bz2;patch=1 \
11            file://jornada7xx.patch;patch=0 \
12            file://defconf_jlime "
13
14 S = "${WORKDIR}/linux-2.6.18"
15
16 inherit kernel
17
18 #Lets let 3.4.x handle the compilation of this one
19 KERNEL_CCSUFFIX = "-3.4.4"
20
21 ARCH = "arm"
22
23 FILES_kernel-image = "/boot/${KERNEL_IMAGETYPE}*"
24
25 do_configure_prepend() {
26         sed -i 's:\(#include "modpost.h"\):\1\n#include <limits.h>:' ${S}/scripts/mod/sumversion.c
27         install -m 0644 ${WORKDIR}/defconf_jlime ${S}/.config
28 }