sg3-utils: add newer buildable version
[openembedded.git] / recipes / linux / linux-jlime-jornada7xx_2.6.17.bb
1 SECTION = "kernel"
2 DESCRIPTION = "JLime Linux kernel for Arm based Jornada 7xx"
3 LICENSE = "GPLv2"
4 PR = "r0"
5
6 COMPATIBLE_HOST = "arm.*-linux"
7 COMPATIBLE_MACHINE = "jornada7xx"
8
9 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.17.tar.gz \
10            file://defconf_jlime \
11            file://AsmArm-ArchSa1100-Jornada720.patch;patch=0 \
12            file://Cpu-Sa1110-Jornada720.patch;patch=0 \
13            file://Kconfig-Arch-Jornada720.patch;patch=0 \
14            file://Kconfig-Keyboard-Jornada720.patch;patch=0 \
15            file://Kconfig-Touchscreen-Jornada720.patch;patch=0 \
16            file://Kconfig-Video-Jornada720.patch;patch=0 \
17            file://Mach-Sa1100-Jornada720.patch;patch=0 \
18            file://Makefile-Keyboard-Jornada720.patch;patch=0 \
19            file://Makefile-Touchscreen-Jornada720.patch;patch=0 \
20            file://Makefile-Video-Jornada720.patch;patch=0 \
21            file://Newfile-Epson1356fb.patch;patch=0 \
22            file://Newfile-Jornada720_kbd.patch;patch=0 \
23            file://Newfile-Jornada720_ts.patch;patch=0"
24
25 S = "${WORKDIR}/linux-${PV}"
26
27 inherit kernel
28
29 #Lets let 3.4.x handle the compilation of this one
30 KERNEL_CCSUFFIX = "-3.4.4"
31
32 ARCH = "arm"
33 FILES_kernel-image = "/boot/${KERNEL_IMAGETYPE}*"
34
35 do_configure_prepend() {
36         install -m 0644 ${WORKDIR}/defconf_jlime ${S}/.config
37 }