sg3-utils: add newer buildable version
[openembedded.git] / recipes / linux / linux-ixp4xx_2.6.21.7.bb
1 require linux.inc
2 require linux-ixp4xx.inc
3
4 VANILLA_VERSION = "2.6.21"
5 KERNEL_RELEASE = "2.6.21.7"
6
7 PV = "${KERNEL_RELEASE}+svnr${SRCPV}"
8 PR = "r0"
9
10 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${VANILLA_VERSION}.tar.bz2 \
11            ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${KERNEL_RELEASE}.bz2;patch=1 \
12            svn://svn.nslu2-linux.org/svnroot/kernel/trunk/patches;module=${VANILLA_VERSION};proto=http \
13            file://defconfig-${KERNEL_RELEASE}"
14
15 S = "${WORKDIR}/linux-${VANILLA_VERSION}"
16
17 do_prepatch() {
18         mv ${WORKDIR}/${VANILLA_VERSION} ${S}/patches && cd ${S} && quilt push -av
19         mv patches patches.ixp4xx
20         mv .pc .pc.old
21         mv ${WORKDIR}/defconfig-${KERNEL_RELEASE} ${WORKDIR}/defconfig
22 }
23
24 addtask prepatch after do_unpack before do_patch