sg3-utils: add newer buildable version
[openembedded.git] / recipes / linux / linux-ixp4xx_2.6.19.bb
1 require linux.inc
2 require linux-ixp4xx.inc
3
4 KERNEL_RELEASE = "2.6.19"
5
6 PV = "${KERNEL_RELEASE}+svnr${SRCPV}"
7 PR = "r0"
8
9 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${KERNEL_RELEASE}.tar.bz2 \
10            svn://svn.nslu2-linux.org/svnroot/kernel/trunk/patches;module=${KERNEL_RELEASE};proto=http \
11            file://defconfig-${KERNEL_RELEASE}"
12
13 S = "${WORKDIR}/linux-${KERNEL_RELEASE}"
14
15 do_prepatch() {
16         mv ${WORKDIR}/${KERNEL_RELEASE} ${S}/patches && cd ${S} && quilt push -av
17         mv patches patches.ixp4xx
18         mv .pc .pc.old
19         mv ${WORKDIR}/defconfig-${KERNEL_RELEASE} ${WORKDIR}/defconfig
20 }
21
22 addtask prepatch after do_unpack before do_patch