sg3-utils: add newer buildable version
[openembedded.git] / recipes / linux / linux-h1940_2.6.17-h1940.bb
1 DESCRIPTION = "Linux kernel for h1940 devices."
2 SECTION = "kernel"
3 LICENSE = "GPLv2"
4
5 PR = "r1"
6
7 COMPATIBLE_HOST = "arm.*-linux"
8 COMPATIBLE_MACHINE = "h1940"
9
10 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.17.tar.bz2 \
11            http://rtpnet.nerim.net/ipaq/patches/2.6.17-1/v2.6.17-gitcurrent.patch;patch=1 \
12            http://rtpnet.nerim.net/ipaq/patches/2.6.17-1/full.patch;patch=1 \
13            http://rtpnet.nerim.net/ipaq/patches/2.6.17-1/WIP/serial_sparse.patch;patch=1 \
14            http://rtpnet.nerim.net/ipaq/patches/2.6.17-1/WIP/h1940_leds.patch;patch=1 \
15            http://rtpnet.nerim.net/ipaq/patches/2.6.17-1/WIP/bluetooth.patch;patch=1 \
16            http://rtpnet.nerim.net/ipaq/patches/2.6.17-1/WIP/h1940_batt.patch;patch=1 \
17            http://rtpnet.nerim.net/ipaq/patches/2.6.17-1/WIP/mtd_partition.patch;patch=1 \
18            http://anymore.nl/ipaq/usbgadget_fixups.patch;patch=1 \
19            http://anymore.nl/ipaq/udc_usb_gadget_register_driver_fix.patch;patch=1 \
20            http://anymore.nl/ipaq/udc_unbind.patch;patch=1 \
21            file://defconfig"
22
23 S = "${WORKDIR}/linux-2.6.17"
24
25 inherit kernel
26
27 do_configure() {
28         install -m 0644 ${WORKDIR}/defconfig ${S}/.config
29         yes '' | oe_runmake oldconfig
30 }