sg3-utils: add newer buildable version
[openembedded.git] / recipes / linux / linux-gumstix_2.6.15.bb
1 DESCRIPTION = "Linux Kernel for the Gumstix"
2 SECTION = "kernel"
3 LICENSE = "GPLv2"
4 PR = "r2"
5
6 DEPENDS = "u-boot-utils-native"
7
8 COMPATIBLE_MACHINE = "gumstix"
9
10 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
11                    cvs://anoncvs:anoncvs@cvs.infradead.org/home/cvs;module=mtd;date=20060223 \
12            file://defconfig-gumstix \
13                    file://arch-config.patch;patch=1 \
14                    file://board-init.patch;patch=1 \
15                    file://compact-flash.patch;patch=1 \
16                    file://defconfig.patch;patch=1 \
17                    file://flash.patch;patch=1 \
18                    file://header.patch;patch=1 \
19                    file://kconfig-arch-cleanup.patch;patch=1 \
20                    file://pxa255-gpio-count-bugfix.patch;patch=1 \
21                    file://pxa2xx_udc.patch;patch=1 \
22                    file://bkpxa-pxa-cpu.patch;patch=1 \
23                    file://bkpxa-pxa-cpufreq.patch;patch=1 \
24                    file://bkpxa-pxa-ac97.patch;patch=1 \
25                    file://rmk-2022-2-rtctime-sa110-pxa255-driver.patch;patch=1 \
26                    file://proc-gpio.patch;patch=1 \
27                    file://serial-ether-addr.patch;patch=1 \
28                    file://cpufreq-better-freqs.patch;patch=1 \
29                    file://ethernet-config.patch;patch=1 \
30                    file://smc-ether-addr.patch;patch=1 \
31                    file://audio.patch;patch=1 \
32                    file://cpufreq-ondemand-by-default.patch;patch=1 \
33                    file://modular-init-bluetooth.patch;patch=1 \
34                    file://modular-init-smc91x.patch;patch=1 \
35                    file://modular-init-usb-gadget.patch;patch=1 \
36                    file://bugfix-i2c-include.patch;patch=1 \
37                    file://bugfix-mmc-clock.patch;patch=1 \
38                    file://bugfix-mtd-onenand.patch;patch=1 \
39                    file://bugfix-pxa-audio.patch;patch=1 \
40                    file://bugfix-pxa-cpufreq.patch;patch=1 \
41                    file://bugfix-pxa-serial-mctrl.patch;patch=1 \
42                    file://bugfix-rndis.patch;patch=1 \
43                    file://bugfix-serial-interrupt.patch;patch=1 \
44                    file://bugfix-serial-register-status.patch;patch=1 \
45                    file://mach-types-fix.patch;patch=1 \
46                    file://mmc-version4.patch;patch=1 \
47                    file://kernel-osx.patch;patch=1 \
48                    file://ucb1400-touchscreen.patch;patch=1 \
49                    file://add_input_randomness_export.patch;patch=1 \
50                    file://kobject_get_path_export.patch;patch=1 \
51                    file://ucb1400-ac97-audio.patch;patch=1 \
52                    file://i2c-gpl-module-fix.patch;patch=1  \
53                    file://disable-uncompress-message.patch;patch=1 \
54                    file://gumstix-mmc.patch;patch=1 \
55                    file://rmk_pxa_mmc_timeout.patch;patch=1"
56
57 S = "${WORKDIR}/linux-${PV}"
58
59 inherit kernel
60
61 COMPATIBLE_HOST = "arm.*-linux"
62 ARCH = "arm"
63 KERNEL_IMAGETYPE = "uImage"
64
65 do_unpack_extra() {
66         cd ${WORKDIR}/mtd
67         ./patchkernel.sh -c -2 -y ${WORKDIR}/linux-${PV}
68 }
69 addtask unpack_extra after do_unpack before do_patch
70
71 do_configure_prepend() {
72         install -m 0644 ${WORKDIR}/defconfig-gumstix ${S}/.config
73 }
74
75 do_deploy_append() {
76         ${HOST_PREFIX}objcopy -O binary -R .note -R .comment -S arch/arm/boot/compressed/vmlinux arch/arm/boot/compressed/linux.bin
77         mkimage -A arm -O linux -T kernel -C none -a 0xa0008000 -e 0xa0008000 -n "gumstix" -d arch/arm/boot/compressed/linux.bin arch/arm/boot/uImage
78                 install -d ${DEPLOY_DIR_IMAGE}
79                 cp arch/arm/boot/uImage ${DEPLOY_DIR_IMAGE}/uImage-${PN}-${PV}
80 }
81
82 PACKAGES += "kernel-modules-sound kernel-modules-bluetooth kernel-modules-pcmcia kernel-modules-ide kernel-modules-ethernet kernel-modules-wireless kernel-modules-usb kernel-modules-mmc kernel-modules-fat kernel-modules-nfs"
83
84 ALLOW_EMPTY_kernel-modules-sound = "1"
85 ALLOW_EMPTY_kernel-modules-bluetooth = "1"
86 ALLOW_EMPTY_kernel-modules-pcmcia = "1"
87 ALLOW_EMPTY_kernel-modules-ide = "1"
88 ALLOW_EMPTY_kernel-modules-ethernet = "1"
89 ALLOW_EMPTY_kernel-modules-wireless = "1"
90 ALLOW_EMPTY_kernel-modules-usb = "1"
91 ALLOW_EMPTY_kernel-modules-mmc = "1"
92 ALLOW_EMPTY_kernel-modules-fat = "1"
93 ALLOW_EMPTY_kernel-modules-nfs = "1"
94
95 RDEPENDS_kernel-modules-sound = "kernel-module-soundcore kernel-module-snd kernel-module-snd-timer kernel-module-snd-pxa2xx-pcm kernel-module-snd-pxa2xx-ac97 kernel-module-snd-pcm kernel-module-snd-pcm-oss kernel-module-snd-page-alloc kernel-module-snd-mixer-oss kernel-module-snd-ac97-codec kernel-module-snd-ac97-bus"
96 RDEPENDS_kernel-modules-bluetooth = "kernel-module-bluetooth kernel-module-bnep kernel-module-gumstix-bluetooth kernel-module-hci-uart kernel-module-l2cap kernel-module-sco kernel-module-rfcomm"
97 RDEPENDS_kernel-modules-pcmcia = "kernel-module-pcmcia-core kernel-module-pcmcia kernel-module-pxa2xx-core kernel-module-pxa2xx-cs "
98 RDEPENDS_kernel-modules-ide = "kernel-modules-pcmcia kernel-module-ide-core kernel-module-ide-cs kernel-module-ide-disk kernel-module-ide-generic kernel-module-firmware-class"
99 RDEPENDS_kernel-modules-ethernet = "kernel-module-mii kernel-module-smc91x kernel-module-gumstix-smc91x"
100 RDEPENDS_kernel-modules-wireless = "kernel-module-ieee80211 kernel-module-ieee80211-crypt kernel-module-ieee80211-crypt-wep kernel-modules-pcmcia kernel-module-hermes kernel-module-hostap-cs kernel-module-hostap kernel-module-orinoco kernel-module-orinoco-cs kernel-module-spectrum-cs"
101 RDEPENDS_kernel-modules-usb = "kernel-module-gumstix-gadget kernel-module-g-ether kernel-module-pxa2xx-udc "
102 RDEPENDS_kernel-modules-mmc = "kernel-module-mmc-core kernel-module-mmc-block kernel-module-pxamci"
103 RDEPENDS_kernel-modules-fat = "kernel-module-vfat kernel-module-nls-base kernel-module-fat kernel-module-nls-cp437 kernel-module-nls-iso8859-1"
104 RDEPENDS_kernel-modules-nfs = "kernel-module-nfs kernel-module-sunrpc kernel-module-lockd"
105
106 module_autoload_pxamci = "pxamci"
107 module_autoload_mmc_block = "mmc_block"
108 module_autoload_gumstix_gadget = "gumstix_gadget"
109 module_autoload_g_ether = "g_ether"