sg3-utils: add newer buildable version
[openembedded.git] / recipes / linux / linux-epia_2.6.19.2.bb
1 SECTION = "kernel"
2 DESCRIPTION = "Linux kernel for VIA EPiA"
3 LICENSE = "GPLv2"
4 PR = "r1"
5
6 KERNEL_CCSUFFIX = "-3.3.4"
7
8 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
9            file://epia_defconfig \
10            file://linux-2.6-limits.patch;patch=1"
11 S = "${WORKDIR}/linux-${PV}"
12
13 COMPATIBLE_HOST = 'i.86.*-linux'
14
15 inherit kernel
16
17 ARCH = "i386"
18
19 # Don't want kernel in rootfs
20 FILES_kernel = ""
21 ALLOW_EMPTY_kernel = "1"
22 PACKAGES += "kernel-image"
23 FILES_kernel-image = "/boot/${KERNEL_IMAGETYPE}*"
24
25 do_configure_prepend() {
26         install -m 0644 ${WORKDIR}/epia_defconfig ${S}/.config
27 }