sg3-utils: add newer buildable version
[openembedded.git] / recipes / linux / linux-efika_2.6.21+git.bb
1 DESCRIPTION = "Linux Kernel for the EFIKA dev platform"
2 SECTION = "kernel"
3 LICENSE = "GPLv2"
4 PR = "r0"
5 PV = "2.6.21+git${SRCDATE}"
6
7 DEFAULT_PREFERENCE = "-1"
8
9 COMPATIBLE_MACHINE = "efika"
10
11 SRC_URI = "file://defconfig"
12
13 S = "${WORKDIR}/linux-2.6"
14
15 inherit kernel
16
17 export ARCH="powerpc"
18
19
20 do_fetch () {
21         cd ${WORKDIR}
22         git clone git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git
23         cd linux-2.6
24         git fetch git://git.secretlab.ca/git/linux-2.6.git 52xx-dev:sl-52xx
25         git checkout sl-52xx
26         # todo: fix to revision f20d894bd207f8bae9b7869fa039a83e7ab2c6d8 here. It works.
27         mkdir patches
28         cd patches
29         wget http://www.246tnt.com/mpc52xx/2.6.22/0006-powerpc-Set-efika-s-device_type-to-soc.patch
30         wget http://www.246tnt.com/mpc52xx/2.6.22/0007-serial-powerpc-Don-t-shutdown-TX-on-mpc5200-serial.patch
31         wget http://www.246tnt.com/mpc52xx/2.6.22/0008-powerpc-mpc52xx-suspend-to-deep-sleep.patch
32 }
33
34 do_patch() {
35         cd ${S}
36         patch -F40 -p1 -i patches/0006-powerpc-Set-efika-s-device_type-to-soc.patch
37         patch -F40 -p1 -i patches/0007-serial-powerpc-Don-t-shutdown-TX-on-mpc5200-serial.patch
38         patch -F40 -p1 -i patches/0008-powerpc-mpc52xx-suspend-to-deep-sleep.patch
39 }
40
41 do_configure() {
42                 install -m 644 ${WORKDIR}/defconfig ${S}/.config
43                 make ARCH=${ARCH} oldconfig
44 }
45
46 do_stage_append () {
47 #need ppc platforms includes + friends in order for external kernel modules to compile as headers as still split
48
49        install -d ${STAGING_KERNEL_DIR}/arch/
50        cp -pPR arch/ppc ${STAGING_KERNEL_DIR}/arch/
51        cp -pPR arch/powerpc ${STAGING_KERNEL_DIR}/arch/
52
53        install -d ${STAGING_KERNEL_DIR}/include/asm
54        cp -pPR include/asm-powerpc ${STAGING_KERNEL_DIR}/include/
55        cp -pPR include/asm-ppc ${STAGING_KERNEL_DIR}/include/
56 }