sg3-utils: add newer buildable version
[openembedded.git] / recipes / linux / linux-davinci_2.6.30.bb
1 require linux.inc
2
3 DESCRIPTION = "Linux kernel for Davinci processors"
4 KERNEL_IMAGETYPE = "uImage"
5
6 COMPATIBLE_MACHINE = "(dm6446-evm|dm6467-evm|dm355-evm|davinci-sffsdr|dm355-leopard)"
7
8 DEFAULT_PREFERENCE = "1"
9
10 SRCREV = "5212151f26e688416faac9f6f33ddd958f7de96c"
11
12 # The main PR is now using MACHINE_KERNEL_PR, for davinci see conf/machine/include/davinci.inc
13 PV = "2.6.30-${PR}+gitr${SRCREV}"
14
15 SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/khilman/linux-davinci.git;protocol=git \
16            file://defconfig"
17
18 # Need checking
19 SRC_URI_append_davinci-sffsdr = " \
20            file://0001-USB-musb-cppi-bugfixes.patch;patch=1 \
21            file://0002-ARM-Mark-unsupported-syscalls-as-IGNORE.patch;patch=1 \
22            file://0003-Add-macros-for-enabling-a-UART.patch;patch=1 \
23            file://0004-Davinci-Enable-MAC-address-to-be-specified-on-kerne.patch;patch=1 \
24            file://0005-Add-DAS-Mini-DAS-and-AFE-USB-machine-types.patch;patch=1 \
25            file://0006-ALSA-ASoC-DaVinci-Fix-SFFSDR-compilation-error.patch;patch=1 \
26            file://0007-ALSA-ASoC-Davinci-Fix-SFFSDR-FPGA-module-codec-FS.patch;patch=1 \
27            file://0008-ALSA-ASoC-Davinci-Fix-incorrect-machine-type-for.patch;patch=1 \
28            file://0009-sound-ASoC-Fix-DaVinci-module-unload-error.patch;patch=1 \
29            file://0010-Add-generic-FPGA-bitstream-loader-driver.patch;patch=1 \
30            file://0011-Add-lyrvpss-example-driver-for-the-SFFSDR-board.patch;patch=1 \
31            file://0012-Update-SFFSDR-to-support-FPGA-and-lyrvpss-drivers.patch;patch=1 \
32           "
33
34 S = "${WORKDIR}/git"