sg3-utils: add newer buildable version
[openembedded.git] / recipes / linux / linux-colinux_2.6.10.bb
1 SECTION = "kernel"
2 DESCRIPTION = "User Mode Linux Kernel"
3 LICENSE = "GPLv2"
4 COLV = "0.6.2"
5
6 COMPATIBLE_MACHINE = "colinux"
7
8 #http://internap.dl.sourceforge.net/sourceforge/colinux/coLinux-${COLV}.tar.gz
9 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
10            file://colinux-${COLV}.patch;patch=1 \
11            file://defconfig"
12
13 S = "${WORKDIR}/linux-${PV}"
14
15 inherit kernel
16
17 COMPATIBLE_HOST = "i.86.*-linux"
18 KERNEL_IMAGETYPE = "vmlinux"
19 KERNEL_OUTPUT = "./${KERNEL_IMAGETYPE}"
20
21 do_configure() {
22         echo '-co-${COLV}' > localversion-cooperative
23         install -m 0644 ${WORKDIR}/defconfig .config
24         kernel_do_configure
25 }