sg3-utils: add newer buildable version
[openembedded.git] / recipes / linux / linux-colinux_2.4.28.bb
1 SECTION = "kernel"
2 DESCRIPTION = "User Mode Linux Kernel"
3 LICENSE = "GPLv2"
4 COLV = "0.6.1"
5
6 COMPATIBLE_MACHINE = "colinux"
7
8 #http://internap.dl.sourceforge.net/sourceforge/colinux/coLinux-0.6.1.tar.gz
9 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.4/linux-${PV}.tar.bz2 \
10            file://colinux-${COLV}.patch;patch=1 \
11            file://nofpu.patch;patch=1 \
12            file://shortloadbytes.patch;patch=1 \
13            file://gcc-registerparanoia.patch;patch=1 \
14            file://linux-2.4.24-attribute-used.patch;patch=1 \
15            file://gcc340-fixes-v2.4.26-try3.patch;patch=1 \
16            file://defconfig"
17
18 S = "${WORKDIR}/linux-${PV}"
19
20 inherit kernel
21
22 COMPATIBLE_HOST = "i.86.*-linux"
23 KERNEL_IMAGETYPE = "vmlinux"
24 KERNEL_OUTPUT = "./${KERNEL_IMAGETYPE}"
25
26 do_configure() {
27         install -m 0644 ${WORKDIR}/defconfig .config
28         kernel_do_configure
29 }