Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[openembedded.git] / recipes / linux / linux-bast_2.4.25-vrs1-bast1.bb
1 SECTION = "kernel"
2 DESCRIPTION = "Linux kernel for Simtec EB2410ITX"
3 LICENSE = "GPL"
4 KV = "2.4.25"
5
6 KERNEL_CCSUFFIX = "-3.3.3"
7 COMPATIBLE_HOST = "arm.*-linux"
8
9 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.4/linux-${KV}.tar.bz2 \
10            ftp://ftp.arm.linux.org.uk/pub/armlinux/source/kernel-patches/v2.4/patch-2.4.25-vrs1.bz2;patch=1 \
11            http://www.simtec.co.uk/products/SWLINUX/files/patch-2.4.25-vrs1-bast1.bz2;patch=1 \
12            file://defconfig \
13            file://mkdep.patch;patch=1 \
14            file://defconfig"
15 S = "${WORKDIR}/linux-${KV}"
16
17 inherit kernel
18
19
20 do_configure_prepend() {
21         cp ${WORKDIR}/defconfig ${S}/.config
22 }