sg3-utils: add newer buildable version
[openembedded.git] / recipes / linux / ipod_2.4.24-ipod0.bb
1 SECTION = "kernel"
2 DESCRIPTION = "Linux kernel for Ipods"
3 LICENSE = "GPLv2"
4 KV = "2.4.24"
5 PV = "${KV}-ipod0"
6
7 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.4/linux-${KV}.tar.bz2 \
8            http://www.uclinux.org/pub/uClinux/uClinux-2.4.x/uClinux-2.4.24-uc0.diff.gz;patch=1 \
9            ${SOURCEFORGE_MIRROR}/ipodlinux/uclinux-2.4.24-ipod0.patch.gz;patch=1  "
10
11 S = "${WORKDIR}/linux-${KV}"
12
13 COMPATIBLE_MACHINE = "ipod"
14
15 inherit kernel
16
17 EXTRA_OEMAKE = ""
18 do_configure_prepend() {
19         install -m 0644 ${S}/arch/armnommu/def-configs/ipod ${S}/.config
20 }
21
22 do_compile() {
23         unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
24         oe_runmake
25 }