sg3-utils: add newer buildable version
[openembedded.git] / recipes / linux / gumstix_2.6.5-gnalm1-gum0.bb
1 BROKEN = "1"
2 #linux-2.6.5-gnalm1-gum0.patch is not fetchable
3
4 SECTION = "kernel"
5 DESCRIPTION = "Linux kernel for OMAP processors"
6 LICENSE = "GPLv2"
7
8 COMPATIBLE_MACHINE = "gumstix"
9
10 # NOTE: pulled local linux-2.6.5-gnalm1, since it didn't apply cleanly
11 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.5.tar.bz2 \
12            file://linux-2.6.5-gnalm1.patch;patch=1 \
13            http://gumstix.superlucidity.net/downloads/kernel/patches/linux-2.6.5-gnalm1-gum0.patch;patch=1 \
14            file://defconfig"
15 S = "${WORKDIR}/linux-2.6.5"
16
17 inherit kernel
18
19
20 do_configure_prepend() {
21         install -m 0644 ${WORKDIR}/defconfig ${S}/.config || die "no default configuration for ${MACHINE} available."
22         oe_runmake oldconfig
23 }
24
25 COMPATIBLE_HOST = 'arm.*-linux'