sg3-utils: add newer buildable version
[openembedded.git] / recipes / linux / ep93xx-kernel_2.6.19+2.6.20-rc7.bb
1 DESCRIPTION = "Linux Kernel for Cirrus Logic ep39xx compatible machines"
2 SECTION = "kernel"
3 LICENSE = "GPLv2"
4 PR = "r1"
5
6 COMPATIBLE_MACHINE = "ep93xx"
7
8 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.19.tar.bz2 \
9            ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/testing/patch-2.6.20-rc7.bz2;patch=1 \
10            file://dynamic-phys-offset-2.6.20-rc7.diff;patch=1 \ 
11            file://defconfig \
12                    "
13
14 S = "${WORKDIR}/linux-2.6.19"
15
16 inherit kernel
17
18
19
20
21 do_configure() {
22         rm -f ${S}/.config
23
24         if [ ! -e ${WORKDIR}/defconfig ]; then
25                 die "No default configuration for ${MACHINE} available."
26         fi
27
28
29         if [ "${TARGET_OS}" == "linux-gnueabi" -o  "${TARGET_OS}" == "linux-uclibceabi" ]; then
30                 echo "CONFIG_AEABI=y"                   >> ${S}/.config
31                 echo "CONFIG_OABI_COMPAT=y"             >> ${S}/.config
32         else
33                 echo "# CONFIG_AEABI is not set"        >> ${S}/.config
34                 echo "# CONFIG_OABI_COMPAT is not set"  >> ${S}/.config
35         fi
36
37         sed -e '/CONFIG_AEABI/d' \
38             -e '/CONFIG_OABI_COMPAT=/d' \
39             '${WORKDIR}/defconfig' >>'${S}/.config'
40
41         yes '' | oe_runmake oldconfig
42
43
44 }