sg3-utils: add newer buildable version
[openembedded.git] / recipes / libtool / libtool_1.5.24.bb
1 DEFAULT_PREFERENCE = "-1"
2
3 require libtool.inc
4 PR = "${INC_PR}.0"
5
6 SRC_URI = "${GNU_MIRROR}/libtool/libtool-${PV}.tar.gz \
7            file://autotools.patch;patch=1 \
8            file://uclibc.patch;patch=1 \
9            file://never-ever-do-rpath.patch;patch=1" 
10
11 S = "${WORKDIR}/libtool-${PV}"
12
13 PACKAGES = "${PN}-dbg libltdl libltdl-dev ${PN}"
14 FILES_${PN} += "${datadir}/aclocal*"
15 FILES_libltdl = "${libdir}/libltdl.so.*"
16 FILES_libltdl-dev = "${libdir}/libltdl.* ${includedir}/ltdl.h"
17
18 inherit autotools
19
20 EXTRA_AUTORECONF = "--exclude=libtoolize"
21
22 do_configure () {
23         find ${S} -name acinclude.m4 | for m4 in `cat`; do
24                 cat ${S}/libtool.m4 ${S}/ltdl.m4 > $m4
25         done
26         autotools_do_configure
27 }
28
29 do_stage () {
30         oe_libinstall -a -so -C libltdl libltdl ${STAGING_LIBDIR}
31         install -m 0644 libltdl/ltdl.h ${STAGING_INCDIR}/
32 }