sg3-utils: add newer buildable version
[openembedded.git] / recipes / libtool / libtool_1.5.22.bb
1 DEFAULT_PREFERENCE = "-1"
2
3 require libtool.inc
4 PR = "${INC_PR}.0"
5
6 SRC_URI = "${GNU_MIRROR}/libtool/libtool-${PV}.tar.gz \
7            file://autotools.patch;patch=1 \
8            file://uclibc.patch;patch=1"
9 #          file://3figures.patch;patch=1"
10 S = "${WORKDIR}/libtool-${PV}"
11
12 PACKAGES = "${PN}-dbg libltdl libltdl-dev ${PN}"
13 FILES_${PN} += "${datadir}/aclocal*"
14 FILES_libltdl = "${libdir}/libltdl.so.*"
15 FILES_libltdl-dev = "${libdir}/libltdl.* ${includedir}/ltdl.h"
16
17 inherit autotools
18
19 EXTRA_AUTORECONF = "--exclude=libtoolize"
20
21 do_configure () {
22         find ${S} -name acinclude.m4 | for m4 in `cat`; do
23                 cat ${S}/libtool.m4 ${S}/ltdl.m4 > $m4
24         done
25         autotools_do_configure
26 }
27
28 do_stage () {
29         oe_libinstall -a -so -C libltdl libltdl ${STAGING_LIBDIR}
30         install -m 0644 libltdl/ltdl.h ${STAGING_INCDIR}/
31 }