sg3-utils: add newer buildable version
[openembedded.git] / recipes / libtool / libtool-cross_1.5.22.bb
1 DEFAULT_PREFERENCE = "-1"
2
3 require libtool_${PV}.bb
4
5 PR = "${INC_PR}.0"
6 PACKAGES = ""
7 SRC_URI_append = " file://libdir-la.patch;patch=1 \
8                    file://prefix.patch;patch=1 \
9                    file://tag.patch;patch=1 \
10                    file://tag1.patch;patch=1 \
11 #                   file://rpath.patch;patch=1 \
12                    file://install-path-check.patch;patch=1"
13 S = "${WORKDIR}/libtool-${PV}"
14
15 prefix = "${STAGING_DIR_NATIVE}${prefix_native}"
16 exec_prefix = "${STAGING_DIR_NATIVE}${prefix_native}"
17 bindir = "${STAGING_BINDIR_NATIVE}"
18
19 do_compile () {
20         :
21 }
22
23 do_stage () {
24         install -m 0755 ${HOST_SYS}-libtool ${bindir}/${HOST_SYS}-libtool
25         install -m 0644 libltdl/ltdl.h ${STAGING_INCDIR}/
26         install -d ${STAGING_DIR_HOST}${target_datadir}/libtool ${STAGING_DIR_HOST}${target_datadir}/aclocal
27         install -c config.guess ${STAGING_DIR_HOST}${target_datadir}/libtool/
28         install -c config.sub ${STAGING_DIR_HOST}${target_datadir}/libtool/
29         install -c -m 0644 ltmain.sh ${STAGING_DIR_HOST}${target_datadir}/libtool/
30         install -c -m 0644 libtool.m4 ${STAGING_DIR_HOST}${target_datadir}/aclocal/
31         install -c -m 0644 ltdl.m4 ${STAGING_DIR_HOST}${target_datadir}/aclocal/
32 }
33
34 do_install () {
35         :
36 }