dosfstools: update to 3.0.28
[openembedded.git] / recipes / libpcre / libpcre_7.6.bb
1 DESCRIPTION = "Perl-compatible regular expression library. PCRE has its own native \
2 API, but a set of 'wrapper' functions that are based on the POSIX API \
3 are also supplied in the library libpcreposix. Note that this just \
4 provides a POSIX calling interface to PCRE; the regular expressions \
5 themselves still follow Perl syntax and semantics. The header file for \
6 the POSIX-style functions is called pcreposix.h."
7 SECTION = "devel"
8 PR = "r6"
9 LICENSE = "BSD"
10 SRC_URI = "${SOURCEFORGE_MIRROR}/pcre/pcre-${PV}.tar.bz2 \
11            file://pcre-cross.patch;patch=1"
12 S = "${WORKDIR}/pcre-${PV}"
13
14 PROVIDES = "pcre"
15
16 inherit autotools binconfig
17
18 PARALLEL_MAKE = ""
19
20 CFLAGS_append = " -D_REENTRANT"
21 CXXFLAGS_powerpc += "-lstdc++"
22 EXTRA_OECONF = " --with-link-size=2 --enable-newline-is-lf --with-match-limit=10000000 --enable-rebuild-chartables --enable-utf8"
23
24 do_compile () {
25         # stop libtool from trying to link with host libraries - fix from #33
26         # this resolve build problem on amd64 - #1015
27         if [ -e ${S}/${TARGET_SYS}-libtool ] ; then
28                 sed -i 's:-L\$:-L${STAGING_LIBDIR} -L\$:' ${S}/${TARGET_SYS}-libtool
29         else
30                 ln -sf ${S}/libtool ${S}/${TARGET_SYS}-libtool
31                 sed -i 's:-L\$:-L${STAGING_LIBDIR} -L\$:' ${S}/${TARGET_SYS}-libtool    
32         fi
33
34         # The generation of dftables can lead to timestamp problems with ccache
35         # because the generated config.h seems newer.  It is sufficient to ensure that the
36         # attempt to build dftables inside make will actually work (foo_FOR_BUILD is
37         # only used for this).
38         oe_runmake CC_FOR_BUILD="${BUILD_CC}" CFLAGS_FOR_BUILD="-DLINK_SIZE=2 -I${S}/include" LINK_FOR_BUILD="${BUILD_CC} -L${S}/lib"
39 }
40
41 do_stage () {
42         autotools_stage_all
43         install -d ${STAGING_BINDIR}
44         install -m 0755 ${D}${bindir}/pcre-config ${STAGING_BINDIR}/
45 }
46 python populate_packages_prepend () {
47         pcre_libdir = bb.data.expand('${libdir}', d)
48         pcre_libdir_dbg = bb.data.expand('${libdir}/.debug', d)
49         do_split_packages(d, pcre_libdir, '^lib(.*)\.so$', 'lib%s-dev', 'libpcre %s development package', extra_depends='${PN}-dev', allow_links=True)
50         do_split_packages(d, pcre_libdir, '^lib(.*)\.la$', 'lib%s-dev', 'libpcre %s development package', extra_depends='${PN}-dev')
51         do_split_packages(d, pcre_libdir, '^lib(.*)\.a$', 'lib%s-dev', 'libpcre %s development package', extra_depends='${PN}-dev')
52         do_split_packages(d, pcre_libdir, '^lib(.*)\.so\.*', 'lib%s', 'libpcre %s library', extra_depends='', allow_links=True)
53 }
54
55 FILES_${PN} = "${libdir}/libpcre.so.*"
56 FILES_${PN}-dev += "${bindir}/*"