xf86-video-omapfb: pandora: handle cycle/forcer events better
[openembedded.git] / recipes / krb / krb5_1.6.3.bb
1 DESCRIPTION = "A network authentication protocol"
2 HOMEPAGE = "http://web.mit.edu/Kerberos/"
3 SECTION = "console/network"
4 PR = "r6"
5 LICENSE = "MIT"
6 DEPENDS = "perl-native ncurses util-linux-ng e2fsprogs-native"
7
8 inherit autotools binconfig
9
10 SRC_URI = "http://web.mit.edu/kerberos/dist/krb5/1.6/krb5-1.6.3-signed.tar \
11            file://fix-uclibc-ruserpass-collision.patch \
12            file://copyperms.patch"
13
14 S = "${WORKDIR}/${PN}-${PV}/src/"
15
16 # Will clean this up...
17 EXTRA_OECONF += " --without-tcl krb5_cv_attr_constructor_destructor=yes ac_cv_func_regcomp=yes \
18                   ac_cv_printf_positional=yes ac_cv_file__etc_environment=yes \
19                   ac_cv_file__etc_TIMEZONE=no --with-system-et"
20 CFLAGS_append += "-DDESTRUCTOR_ATTR_WORKS=1 -I${STAGING_INCDIR}/et"
21 LDFLAGS_append += "-lpthread"
22
23 FILES_${PN}-doc += /usr/share/examples
24
25 krb5_do_unpack() {
26         tar xzf ${WORKDIR}/krb5-1.6.3.tar.gz -C ${WORKDIR}/
27         patch -d ${S} -p1 < ${WORKDIR}/fix-uclibc-ruserpass-collision.patch
28         patch -d ${S} -p1 < ${WORKDIR}/copyperms.patch
29 }
30
31 python do_unpack() {
32         bb.build.exec_func('base_do_unpack', d)
33         bb.build.exec_func('krb5_do_unpack', d)
34 }
35
36 do_configure() {
37         oe_runconf
38 }
39
40 do_install_append () {
41         mv ${D}${bindir}/ftp ${D}${bindir}/ftp.${PN}
42         mv ${D}${sbindir}/ftpd ${D}${sbindir}/ftpd.${PN}
43         mv ${D}${bindir}/telnet ${D}${bindir}/telnet.${PN}
44         mv ${D}${sbindir}/telnetd ${D}${sbindir}/telnetd.${PN}
45 }
46
47 pkg_postinst_${PN} () {
48 #!/bin/sh
49         update-alternatives --install ${bindir}/ftp ftp ftp.${PN} 100
50         update-alternatives --install ${sbindir}/ftpd ftpd ftpd.${PN} 100
51         update-alternatives --install ${bindir}/telnet telnet telnet.${PN} 100
52         update-alternatives --install ${sbindir}/telnetd telnetd telnetd.${PN} 100
53 }
54
55 pkg_prerm_${PN} () {
56 #!/bin/sh
57         update-alternatives --remove ftp ftp.${PN} 100
58         update-alternatives --remove ftpd ftpd.${PN} 100
59         update-alternatives --remove telnet telnet.${PN} 100
60         update-alternatives --remove telnetd telnetd.${PN} 100
61 }
62
63 do_stage() {
64         oe_libinstall -so -C util/support libkrb5support ${STAGING_LIBDIR}
65         oe_libinstall -so -C util/et libcom_err ${STAGING_LIBDIR}
66         oe_libinstall -so -C lib/crypto libk5crypto ${STAGING_LIBDIR}
67         oe_libinstall -so -C lib/krb5 libkrb5 ${STAGING_LIBDIR}
68         oe_libinstall -so -C lib/des425 libdes425 ${STAGING_LIBDIR}
69         oe_libinstall -so -C lib/krb4 libkrb4 ${STAGING_LIBDIR}
70         oe_libinstall -so -C lib/gssapi libgssapi_krb5 ${STAGING_LIBDIR}
71         oe_libinstall -so -C lib/rpc libgssrpc ${STAGING_LIBDIR}
72         oe_libinstall -so -C lib/kdb libkdb5 ${STAGING_LIBDIR}
73         oe_libinstall -so -C lib/kadm5/clnt libkadm5clnt ${STAGING_LIBDIR}
74         oe_libinstall -so -C lib/kadm5/srv libkadm5srv ${STAGING_LIBDIR}
75
76         install -d ${STAGING_INCDIR}/krb5
77         for X in krb5.h locate_plugin.h
78         do
79                 install -m 0644 ${S}/include/krb5/$X ${STAGING_INCDIR}/krb5/$X
80         done
81
82         install -d ${STAGING_INCDIR}/gssapi
83         for X in gssapi_generic.h gssapi.h gssapi_krb5.h
84         do
85                 install -m 0644 ${S}/include/gssapi/$X ${STAGING_INCDIR}/gssapi/$X
86         done
87         install -m 0644 ${S}/lib/gssapi/mechglue/mechglue.h ${STAGING_INCDIR}/gssapi/mechglue.h
88
89         install -d ${STAGING_INCDIR}/kerberosIV
90         for X in krb.h des.h mit-copyright.h krb_err.h kadm_err.h
91         do
92                 install -m 0644 ${S}/include/kerberosIV/$X ${STAGING_INCDIR}/kerberosIV/$X
93         done
94
95         install -d ${STAGING_INCDIR}/gssrpc
96         for X in auth.h auth_gss.h auth_gssapi.h auth_unix.h clnt.h netdb.h pmap_clnt.h pmap_prot.h pmap_rmt.h rename.h rpc.h rpc_msg.h svc.h svc_auth.h xdr.h types.h
97         do
98                 install -m 0644 ${S}/include/gssrpc/$X ${STAGING_INCDIR}/gssrpc/$X
99         done
100
101         # com_err.h needs to be added here if you choose to use this builtin
102         for X in krb5.h profile.h gssapi.h
103         do
104                 install -m 0644 ${S}/include/$X ${STAGING_INCDIR}/$X
105         done
106 }