xfce4-battery-plugin: tune the pandora hack
[openembedded.git] / recipes / images / minimal-gpe-image.bb
1 #Angstrom minimal gpe image
2 # This image provides a barebone dm and 'desktop' 
3 # Very angstrom and opkg centric
4
5 XSERVER ?= "xserver-kdrive-fbdev"
6 SPLASH ?= ' ${@base_contains("MACHINE_FEATURES", "screen", "psplash-angstrom", "",d)}'
7
8 export IMAGE_BASENAME = "minimalist-gpe-image"
9
10 PR = "r2"
11
12 DEPENDS = "task-boot"
13 IMAGE_INSTALL = "\
14     ${XSERVER} \
15     task-boot \
16     gpe-dm gpe-session-scripts gpe-login \
17     matchbox-wm \
18     gpe-terminal \
19     angstrom-feed-configs \
20     opkg-nogpg opkg-collateral \
21     ${SPLASH} \
22     "
23
24 #zap root password for release images
25 ROOTFS_POSTPROCESS_COMMAND += '${@base_conditional("DISTRO_TYPE", "release", "zap_root_password; ", "",d)}'
26
27 inherit image