xine: update to new xine recipe
[openembedded.git] / recipes / gxine / gxine_0.4.1.bb
1 DESCRIPTION = "gxine is a front-end for libxine."
2 SECTION = "x11/multimedia"
3 LICENSE = "GPL"
4 DEPENDS = "gtk+ libxine"
5 PR = "r2"
6
7 DEFAULT_PREFERENCE = "-1"
8
9 # Long list of RDEPENDS required to playback mp3/ogg audio and mpeg/mpeg4 video
10 RDEPENDS = "libxine-plugin-vo-out-xshm \
11             libxine-plugin-vo-out-none \
12             libxine-plugin-ao-out-esd \
13             libxine-plugin-ao-out-none \
14             libxine-plugin-inp-file \
15             libxine-plugin-inp-http \
16             libxine-plugin-inp-net \
17             libxine-plugin-inp-mms \
18             libxine-plugin-decode-mad \
19             libxine-plugin-decode-vorbis \
20             libxine-plugin-decode-image \
21             libxine-plugin-decode-ff \
22             libxine-plugin-dmx-audio \
23             libxine-plugin-dmx-mpeg \
24             libxine-plugin-dmx-mpeg-block \
25             libxine-plugin-dmx-mpeg-elem \
26             libxine-plugin-dmx-mpeg-pes \
27             libxine-plugin-dmx-mpeg-ts \
28             libxine-plugin-dmx-ogg \
29             libxine-plugin-dmx-image \
30             libxine-plugin-dmx-avi"
31
32
33 SRC_URI = "${SOURCEFORGE_MIRROR}/xine/${PN}-${PV}.tar.gz \
34            file://disable-browser-plugin.patch;patch=1"
35
36 EXTRA_OECONF = " --includedir=${STAGING_INCDIR} \
37                 --libdir=${STAGING_LIBDIR} \
38                 --disable-xinetest \
39                 --with-xine-prefix=${STAGING_DIR_HOST}${layout_exec_prefix}"
40
41 LDFLAGS += "-lxine"
42
43 inherit autotools pkgconfig
44