xf86-video-omapfb: pandora: handle cycle/forcer events better
[openembedded.git] / recipes / gtkhtml / gtkhtml-3.8_3.12.3.bb
1 DESCRIPTION = "HTML rendering/editing library"
2 SECTION = "x11/libs"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5 DEPENDS = "gtk+ virtual/gail libbonoboui libgnomeprintui libgnomeui"
6 PR = "r2"
7
8 SRC_URI = "${GNOME_MIRROR}/gtkhtml/3.12/gtkhtml-${PV}.tar.bz2 \
9            file://60_glib-2.15-g-gnuc-function.patch;patch=1"
10
11 S = "${WORKDIR}/gtkhtml-${PV}"
12
13 inherit autotools pkgconfig
14
15 EXTRA_OECONF = "--disable-gtk-doc"
16
17 ORBIT_IDL = "${STAGING_BINDIR_NATIVE}/orbit-idl-2"
18
19 do_configure_append() {
20         find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
21         find ${S} -name Makefile | xargs sed -i s:'-I${prefix}/include':'-I.':g
22         find ${S} -name Makefile | xargs sed -i 's|ORBIT_IDL =.*|ORBIT_IDL = ${ORBIT_IDL}|'
23 }
24
25 do_stage() {
26         autotools_stage_all
27 }
28
29 FILES_${PN} += "${datadir}/gtkhtml-3.8"
30