Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[openembedded.git] / recipes / gphoto2 / libgphoto2_2.4.7.bb
1 DESCRIPTION = "libgphoto2 allows you to access digital cameras"
2 SECTION = "libs"
3 LICENSE = "GPL"
4 DEPENDS = "libtool jpeg virtual/libusb0 libexif"
5
6 # The .fdi and .rules files were generated with:
7 #  libgphoto2-2.4.7/packaging/generic$ qemu-arm -s 1048576 -r 2.6.24 -L /OE/angstrom-dev/staging/armv5te-angstrom-linux-gnueabi/ .libs/print-camera-list
8 # They are release specific, so please regen when adding new releases
9
10 SRC_URI = "${SOURCEFORGE_MIRROR}/gphoto/libgphoto2-${PV}.tar.bz2 \
11            file://10-camera-libgphoto2-device.fdi \
12            file://10-camera-libgphoto2.fdi \
13            file://90-libgphoto2.rules \
14 "
15
16 PR = "r1"
17
18 inherit autotools pkgconfig lib_package
19
20 OE_LT_RPATH_ALLOW=":${libdir}:"
21 OE_LT_RPATH_ALLOW[export]="1"
22
23 EXTRA_OECONF = " --with-drivers=all ac_cv_lib_ltdl_lt_dlcaller_register=yes"
24
25 do_install_append() {
26     install -d ${D}${datadir}/hal/fdi/information/20thirdparty
27     install -m 0644 ${WORKDIR}/*.fdi ${D}${datadir}/hal/fdi/information/20thirdparty/
28
29     install -d ${D}${sysconfdir}/udev/rules.d/
30     install -m 0755 ${WORKDIR}/*.rules ${D}${sysconfdir}/udev/rules.d/
31
32     install -d ${D}${bindir}
33     install -m 0755 ${S}/packaging/generic/check-ptp-camera ${D}${bindir}/
34 }
35
36 PACKAGES =+ "libgphotoport libgphoto2-camlibs"
37 FILES_libgphoto2-camlibs = "${libdir}/libgphoto2*/*/*.so*"
38 RDEPENDS_${PN} = "libgphoto2-camlibs"
39
40 FILES_libgphotoport = "${libdir}/libgphoto2_port.so.*" 
41
42 FILES_${PN} += "${libdir}/udev/* ${datadir}/hal"
43 FILES_${PN}-dbg += "${libdir}/*/*/.debug"
44
45
46